Cutting in wrong position

Trying to get to grips with lightburn however i’m confused as to how i’ve managed to cut off centre (vertically)

Using a k40, c3d with lightburn smoothie.

i’ve an image as you can see of the laser cutting vertically off centre, but the material is positoned top left, where the laser head starts, ive set it to absolute position…

and the lightburn bed is also attached… the grey box around the writing is also the material size which i align centre’s with from the lightburn menu.

Additional image shows that an a4 page (which is a bit wonky due to air assist) - cuts the box around it perfectly in line with the material, the text however is not…

After a sad many hours this morning, i’ve figured out that although lightburn allows you to change bed size, etc, it appears c3d is set to 300x200 by default, so lightburn and c3d were arguing, i’ve since moved to 300x200 in lightburn and that appears to be better.

however my next issue is that on job completion the laserhead thinks its a formula 1 driver and goes crazy returning to 0,200

I’ll need to do another FAQ/ Doc on the C3D Forum with “adjusting the C3D Config for the exact bed size of your laser” and a few other tuning things.

The value you seek is the default seek rate in the board’s config file: decrease this. You can also increase the stepper driver currents - the alpha and beta currents, by 0.2 amp steps, until the issue goes away.

Use Sublime Text as your Text Editor.

Hi Ray :slight_smile:

Its pretty self explaining in your really easy config file I think, my issue was not knowing that it needed to change!

Just assumed changing in lightburn would make stuff happen!

Appreciate your reply!

My speed issue was also due to a box I’d mistakenly drawn whilst trying to fix issue above and so it was actually travelling and hitting out of bounds so that’s all fixed too!


still having bizarre issues, i’m obviously doing something wrong…

on the harvie layer, there’s nothing that i can see other than the text, and in the video below (which is upside down, god knows how lol…) - I home’d, then used frame twice, you can see judders at the start, it then frames in the wrong place, then it reframes the same ‘wrong place’, and then homes to where it started…

check out the video and ive attached the lbrn.

horse.lbrn (7.2 KB)

Your machine is trying to move way too fast at the start, and skipping steps. This would be either acceleration, speed, or both.

  • The “default seek rate” value is in mm/min, and changes how fast the machine moves when moving between cuts.
  • The “acceleration” setting, in mm/sec^2, changes how fast the machine tries to get up to that speed.
  • The motor current values Ray mentions above control the amount of holding power sent to the motors. Higher may help, but too high can make the motors resonate (bounce), so there’s a sweet spot.

I would recommend starting by lowering the acceleration until things move without slipping (reliably). Run weird zig-zag cuts at high speeds and make sure it stays on-path for multiple runs of the same job.

Hi Oz,

The settings i’ve got on C3d are as they’ve come out of the box - i’ve changed nothing - and the setting in lightburn is speed ‘100’ which i think i read somewhere you guys changed down from 200.

Can you indicate where the settings i need to look at and decent values for them?

Just as a point of refernce also, if i turn off the harvie layer and turn on another layer, all is well and it lasers as expected.

Ray mentioned this already:

I’d start at 1000 for acceleration, and 9000 for seek rate. Those should be conservative.


The default was:

acceleration 2500 # Acceleration in mm/second/second.
default_seek_rate 24000 # Default rate ( mm/minute ) for G0 moves

I’ve changed it to your suggestion, which to be honest, is more akin to a speed that i like, HOWEVER the harvie layer still causes the juddering, the other layers do not.

I can’t make out any of the settings in the video because it’s squashed, small, and upside down.

You may have the cut out of bounds, which could cause the machine to hit the rails. Post screen shots of your design, the settings in the “Laser” window (specifically what you have “Start From” set to) and the layer settings you’re using. That setting isn’t saved with the file.

This is the issue layer,

The lightburn file is attached above, but basically C03 and C00 layers are the same, just different text - same font, same position - no juddering.

Ahh - you have four empty text objects in your file. It looks like you started some text, then deleted it all, and LightBurn left the empty objects there. I’ll fix that, and in the meantime, here’s your file with them removed.

horse.lbrn (6.4 KB)

Ahh, you’re a hero. :slight_smile:

Yeah i got very disjointed with the text, because i selected one layer then copy/pasted but it ended up on the same layer because it was the same colour, and then somehow ended up on the text tool, which then i guess disappeared because i didnt type anything.

Just by way of knowning, how would i see/fix this whilst you guys do stuff your end?

The lbrn file resulted in this, not sure why the cut isn’t in line with the scan

The easy way is “Select All” - If the bounds around the selection look funny, there’s extra stuff in there. You can deselect the stuff you can see, then just delete.

I just opened the lbrn file in a text editor, which works too.

1 Like

awesome thanks, any idea what caused the cut to be out of line with the scan? despite it doing it in the same job?

My guess would be that you missed a few steps when moving from the end of the scan to the beginning of the cut, which would be either acceleration set too high, rapid move speed too high, or possibly both.