Cutting outside before inside

It’s because the parts are “shattered” instead of continuous shapes. Here’s how LightBurn sees your parts:
image

If you open the file and un-group everything, the outline shown here is all discrete lines and arcs, not one continuous curve. Select everything, ungroup it all, select everything, then Edit -> Auto-Join selected shapes.

My guess is that this came from a DXF file. They’re notorious for this, but this can be improved by setting a non-zero auto-close tolerance here in the settings:
image

Use a small number, like 0.02mm, so it doesn’t join stuff you don’t intend to be joined. If you have the original DXF this came from, email it to me at developer at lightburnsoftware dot com so I can try to see if there’s connectivity information that I’m missing.