Data files blank when sent

I was working a file with no problems and then lightburn froze in the middle of a save. When I did a force close and restarted the software I have been unable to successfully send any data to the laser to run a cut. It starts as if it’s going to cut the file, then immediately goes back to the home position and kicks the green light back on as if ready. I’m not sure if this is a software issue, laser issue or a combo of the two.

I’m running a Mac on Mohave.
Laser is Thunder Laser nova 35 80W.

I’ve tried restarting both the computer and the laser, unplugging literally all electrical and plugging it back in. The file did work previously so I know it’s not a file issue. I even tried opening a new file and just cutting a circle but that’s a no go.

Usually, I send the file to the laser and let it run from the controller so I can work on other stuff on my laptop. I have tried sending the data both to the laser and cutting directly from the software, both are fails. When I send the file to the laser controller first, if I open the file, it’s just blank

Not sure what else to trouble shoot. Any ideas on what I’m doing wrong?

Adding photos to comments as it appears I don’t have the ability to add them on the main post from my phone

Apparently I don’t have permissions to add any photos from mobile so not sure what to do :woman_shrugging:

Are you connected with a USB cable? MacOS includes a driver that conflicts with the one used by Ruida - they fight and cause all kinds of issues. If you can connect the laser with an Ethernet cable, you won’t have the driver issue, and it’s significantly faster.

(I’ve also lifted the posting restrictions, so you should be able to add pics now - that’s mostly to prevent spammers from littering the forum with trash)

It’s ethernet connected. The USB port is taken up by my camera

With a cable, directly from the computer to the laser? If you’re using WIFI, that will be the issue - Ruida controllers use a network protocol that is really designed for direct cable, not WIFI, and it tends to suffer dropouts on WIFI if there’s any interference or other traffic on the network at all.

I see your profile should allow you to post images. You can drag and drop, use copy and paste, for inline additions, or use the Upload button while in edit mode.

That’s correct, no wifi. Direct connection between the laptop and the controller. We just left for an engagement but I can snap photos and try to upload when we get back. I’m still unable to upload the other photos to the forum it seems. I tried but it just shows uploading with the spinning circle and the reply button stays greyed out if I’ve added photos to the reply

I haven’t the slightest clue if this photo will attach. I keep getting a popup saying there was an error converting png to jpg (except these are all jpg since I just snapped them from my phone camera). So if this doesn’t work I’ll send the photos to my laptop and upload when we get back from.

Uploading: 20210716_155205.jpg…

Sorry, the image did not load successfully. It can take some time to upload, as the phone picture can be large, and the mobile connection can be slower than your computer for uploading.

This is just so bizarre to me. I’m now on my laptop and trying to upload photos but I still get this error from my laptop that I did on my mobile

“lib/discourse.rb:87:in `exec’: An error happened when converting from PNG to JPG.” but the photos I’m uploading have been reduced in size to a few KB and aren’t png, they’re jpg.

However, also of note to add, my PC is actually in the “PC” spot on the controller not the ethernet. But i’m definitely NOT using Wifi and I’ve been using the laser successfully for months like this so it would be odd that only now the Mac is having issues with it running to that port when I haven’t done any system updates on the mac at all.

I went back at it this morning and it’s still having the same issues, it’s sending no data to the laser but it’ll kick on like it’s starting then just go back home. I have some old files on the controller from pre-yesterday’s issue and those run just fine because there’s data in there. So I don’t believe it’s a laser issue now.