Desperate help needed

In a nutshell…
I grabbed my laptop off the laser without unplugging the USB and walked away, ripping the USB cable from the laser at an odd angle.
The USB plug on the laser was damaged quite badly, I attempted to straighten out the pins and plug it back into the laptop, which thankfully survived the fall. I can not be certain but when I plugged it back in, one of the pins on the usb cable may have either touched another pin or the metal housing.
Here is where I am at now…
I have removed the USB running from the laser machine frame to the controller. When I power on the laser now, the laser powers up, but the machine no longer resets the laser head position as it always had done at start up. (normally you can hear the slight clunk sound of the motors engaging as the machine resets itself at start up…this is not happening)
I can not move the laser head via the ruida touchpad and the gantry moves freely as if the machine was turned off.
I pressed the test button on the power supply and I see no light dancing in the laser tube as you normally would.

I do not know if I damaged the controller, the power supply or any other components. I could really use some input and would be eternally grateful.

Bodor 1300x900 laser - 100 watts
Ruida RDS-6442S controller

Did you damage the USB plug on the actual controller or a plug extension panel mounted on the machine? If the plug on the controller itself is still intact, try unplugging the panel mount extension from it and power cycle the machine to see if it homes normally on startup.

EDIT: I’m sorry. I just reread your post. Sounds like you have tried this already.

Let’s start with some initial trouble shooting steps to narrow down the issue:

  1. Is the HMI (control panel of the Ruida Controller) responsive to button presses? Can you enter the menu and get to the controller configuration?

If so, check the controller configuration to see if the shorting of pins may have coincidentally provoked a hard reset / factory reset.

  1. Sounds like on the stepper motors, the drivers are not being powered / triggered by the controller. Check the stepper drivers to see if they have any LED indicators such as being powered on.

  2. What do the controller’s status lights indicate? Also are you certain you disconnected both the panel mounted PC-USB and Udisk ports?

The 6442 Status Lights and USB plugs:

The panel buttons work, I will attempt to check the controller config…not sure where that is yet…
Picture above shows lights on controller box.

I REALLY appreciate your time…Ill see if i can find anything in the controller menu now.

EDIT…I have not unplugged the UDISK cable as you can see in the pic.

Your Z Axis limit is triggered (lights 6 and 5) and I am not sure about lights 2 and 4 because I do not have my limit X or Y switches wired using Lmt+. I only use Lmt- for those. But by the looks of it X and Y are limit triggered as well on the opposite of 0,0 (maxed).

on the 6445, the LED status only glows when the limit is triggered. If you have triggered your limit switches, it explains the unresponsiveness.

Any idea what would trigger the limit switches all of a sudden?
I will gladly pay if someone can walk me through this. I have closed my etsy store because of this but still have orders waiting…its a devastating situation Ive created for myself…

Notice my fan…it no longer works either. I have plugged it directly to the wall and it does still work.

Did you move the gantry up against an extreme and activate the limit switches? do you have mechanical or magnetic limit switches?

You will need to trace all of your connections / wiring. Check all of the terminal blocks as well. Do this with the power off. Note the green terminal blocks on the controller unplug in groups (they’re modular). So it is easy to unplug a group (CN5 for example) inspect the wiring / tighten the terminals, then plug it back in.

The limit switches are magnetic. I manually moved the gantry away from x and y and the red lights turned grey. I tried running a file from the controller and still nothing happens. I have checked all connections and everything is good. I did notice the light on one power supply is off. I am sure why it is not getting power yet.
I will send a pic. 5 minutes…

I also found a usb cable from an old printer that is A-B. I managed to plug in the laptop and find the laser via lightburn. I can access all menus and controller info but can not run any programs from the computer or the ruida panel.

Sorry I meant to send this

That 48v DC PSU is your stepper driver / stepper motor power supply. Do you have 120v AC supply to it across neutral and line? (The LED light is not a reliable indicator of functionality)

THIS IS HIGH VOLTAGE A/C so if you are not familiar with safety precautions and protocols for probing with a volt meter, then do not attempt to trouble shoot this.

Once you determine if you have 120v AC on L and N of the PSU, you would need to see if you have 48V DC across COM and any of the V+ terminals.

There’s a lot of potential under that “hood” for you to make contact with 120V AC! Don’t take that lightly.

OK, so there is not 120volts across L5 and N3.
I am just tracing wires to see where they come from…
I am gonna owe you big time for the help…

The L5 wire pictures is where the power should come from, it leaves here, goes to the stepper power supply and splits off to the tube power supply.
I am not sure what those 2 clear Plug in boxes are…??

That is a Chint Electric JQX-13F Miniature High-Power Electromagnetic Relay. Basically, the 24 volt coil of that relay controls a switch that passes the L3 120v through the contacts to L5 and then to your stepper PSU.

Does L3 (the switched line voltage) to Neutral have 120V on it? L3 should be constant 120v. (Should be any Neutral as Neutral shouldn’t be switched anywhere but you never know on these Chinese machines as we must remember they are made for both 120v and 240v North America configurations. I say North America because In NA, 240v consists of split phase @ 180° out of phase 120V RMS legs for the net 240v. In Europe, the 240v supplied is on a single phase across a neutral like our 120v.)

Also, can you take a full view shot of your machine’s guts (the electrical components) for me?

Sorry for the late reply, life got in the way. I won’t be able to get it to you until tomorrow. Thanks again!!!

Well, this is the hardest post I think I’ve ever had to type.
I just got back to my little shop and as soon as I walked in I noticed something…yep…my frickin kill switch was depressed. My heart sank as I recalled the nightmare I put myself through for the last 2 days. I must have hit it while trying to stop the computer from falling on the floor…I don’t know.
I apologize for taking up so much of your time yesterday, Jeff, I can’t thank you enough for stepping up and having my back. I was quite stressed about the whole ordeal and cant even begin to tell you how much of a fool I feel like. I KNOW that is the FIRST thing to check…It just slipped by me, I guess.

Let this be a lesson to everyone, there’s no need for us all to feel silly and embarrassed, Ill take this one for the team…CHECK THE KILL SWITCH!!!
(I may install a siren and 1000 watt stroke light on it so this never happens again.)

You are back up and running thats the important thing

1 Like

And to be honest, the trail of troubleshooting would have lead us there. It was just taking longer due to the remote correspondence.

The E Stop Is generally connected to 24v and is designed to disengage either those relays Mentioned or a contactor (basically a more heavy duty relay).

Glad you’re up and running!