Device Descriptor Failed

Trying to set up my galvo. The system cant find the laser and in the device manager its coming up as the Unkown USB Device (device descriptor failed) and it wont connect when I point it to the EZCAD2 driver

Do you have the proper driver for Lightburn. The EZCad2 driver and Lightburn isn’t compatible with each other.

Good luck


1 Like

The ezcad2 driver comes preloaded in the lightburn download. Either way its not pointing to any driver. It is under universal serial bus controllers as Unknown USB Device (device descriptor failed)

It’s attempting to connect and the device descriptor data doesn’t make sense…

I’d still say you have the wrong drivers… but I don’t do windows. You should still see a device description in you device list.

Mine is shown as

Bus 003 Device 003: ID 9588:9899 BJJCZ USBLMCV4

Maybe @JohnJohn can give you some tips to get you going.


1 Like

The first troubleshooting step that we should attempt is reinstalling the Windows Driver for LightBurn using Zadig.

This installation technique is also presented in the video shared by @jkwilborn at 2:59

Please authorize changes when installing to ensure the drivers are installed completely.

If this doesn’t resolve we can attempt a connection with EZCad2 to confirm that the hardware is fine.

I have tried to use Zadig. It kept failing on the device. Command prompt would just turn on and didnt run anything.
It is not showing up under BJJCZ device or under Universal Serial Bus Devices.

Did you try this?


I received fuller analysis from the team.

Are you connecting with a USB cable?
Are you using a hub, an adapter or a USB-C port on your Windows 11 device?

I just found out that the Device Descriptor Failed error is more likely hardware-related, (Bad port, Bad Cable, Bad control board) than driver-related.

A colleague also mentioned that very few problems are seen with USB-C conversion cables on Windows devices.

You’re right - They’re definitely different drivers and the video showcases how to activate and deactivate both drivers.

Launching EZCad and seeing if their driver is active and if the hardware responds is the next step.

While testing with other software, please shut down LightBurn to prevent USB Port conflicts.

It is a windows 11. This is on 2 different Cloudray devices. It is type A USB to type B USB. where do I get this software?

I might know what’s going on. There are two drivers and they may be in conflict. One driver ships with LightBurn and one ships with EZCad 2.

I grabbed my Windows 11 device for testing.

Close LightBurn for the next few tests.

On the Windows 11 desktop open any file folder and with that window open, navigate to the Local Disk (C:) drive. The selection for me was Lower Left.

Once you’re in the Local Disk (C:) drive click Program Files.
then click LightBurn.
then click EzCad2Driver

You should be here:

C:\Program Files\LightBurn\EzCad2Driver

In the address bar it looks like this:

(a file folder) > This PC > Local Disk (C:) > Program Files > LightBurn > EzCad2Driver

Right-click on the file called dpinst-x64 and select Run as Administrator.

Ok, That’s the first part. Feel free to close the window or if you get an error message press PrtScn (Print Screen) and drag the capture box around the message. Please capture any unanticipated messages so we can get the details. :slight_smile:

Next, open the Device Manager. (Blue Windows symbol at the bottom of the screen - when the window pops open click the search bar in that window and type the word device.) You should have this:

Open the Device Manager - Power up the Galvo Laser - and connect the USB Cable.

When you connect the cable, do you hear the Windows 11 USB connect noise? Mine makes kind of a “Boink” sound. If it’s not present, the board or cable could be bad.

Sometime in the next few seconds, you should have something under:

Universal Serial Bus devices called USBLMCV2.

I don’t know if you’ve seen the click-expand set up on this.
If you click > it will turn into v and expand below.

forum 118685 2023-12-08_20-40-51 uninstall device

If it’s there, Right-click it and in the popup window click Uninstall Device.

(If it’s not there, please let us know and I’ll put an Asterisk * a few lines further down so you can jump over the next few lines.) If you get a weird error message please capture it by clicking PrtScn (Print Screen) and dragging the capture box around the message.

If it’s uninstalling, it’ll look like this.

forum 118685 2023-12-08_20-42-57 USBLMCV2 uninstall

If it asks you if you want to restart, select No.

In the top row, click Action, then select Scan for hardware changes.

If the driver that comes with the galvo and the factory BJJCZ software was installed, the Galvo should show up.

If it reinstalls the universal driver let me know.

It might be a good idea to have a quick look at:

Ports (COM & LPT)
to see if the computer assigned something in an odd way. Again, click the > to expand down.

If you see the BJJCZ device in the Device Manager, launch EZCad2 and see if the laser will frame or make any noise or anything. If it does or doesn’t, it doesn’t matter yet. What does matter is that we have already removed half the potential conflict.

If it wasn’t there, and if you want to experiment with this later, you can download a replacement driver for the Factory EZCad2 software from Laser Everything:

You’ll want the EZCad2_64-bit_Drivers.
Keep it handy but if you didn’t connect to the Galvo with EZCad 2 yet, don’t install this just yet. It can just sit here until we’ve got LightBurn sorted out.

Close EZCad 2.

Launch Zadig. I’m testing with Zadig 2.8.

I don’t have the Galvo controller in front of me, and the Message/Option Bar just below “Device Options Help” should populate and offer to replace the Driver used by EZCad2 where Drivers are listed is blank for me.

If you did connect with the other driver, Zadig should offer you a chance to replace a common driver with a Generic driver. It runs directly from wherever it’s launched and does not require ‘installation’.

The Documentation (also linked above) is showing the quick way through.

List All Devices

Choose LMC Device

Ready to swap the new one in.

Click Replace Driver.

If this doesn’t resolve, you may want to retest the

C:\Program Files\LightBurn\EzCad2Driver

In the address bar it looks like this:

(a file folder) > This PC > Local Disk (C:) > Program Files > LightBurn > EzCad2Driver

Right-click on the file called dpinst-x64 and select Run as Administrator.

If the hardware is still unresponsive, It’s time to try a different cable, check Fuses and Breakers and watch for blinking lights indicating power and communications.

I think I’m all out of suggestions at this point.

First, I would like to thank you for the detailed response and patience.

I ran throught the installation process, and I dont belive there was a issue with the install.
The fundamental issue of this problem is that it doesnt recognize the board so it wont let me force a driver to run. Here is what pops up when I open up device manager.

And Even when I try to use zagit and run it it fails. Like so…


Ive tried to plug a diffrent cable in, I checked continuity on each pin of the cable in, I tested the original cable on a known good system, and I plugged directly into the board instead of the external outlet on the laser.

I bought another board and I will keep you up to date if that fixes this issue.
Thank you.

Is the new board a BJJCZ EZCad 2 board?

Pictures of the old board and new board would be welcome.

the far left is the one I am working with now. The right is the one on the known good system.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.