Did I just find a bug in the latest Lightburn

So yesterday I got the message to upgrade to the latest Lightburn version
But since then it doesn’t honor DXF files correctly.
When I import a DXF file any holes are moved off to the left . This is a repeatable problem. I have checked that the DXF file is good. I open it in other tools with no issue. But not lightburn.
I also noticed that if I create a shape thats not complex it imports fine.
I am stumped. This didn’t happen before.

RG270 New Design Cockpit.3.dxf (110.7 KB)

This might work, the version that your dxf file was create was AC1032 which I don’t have. Try saving your source file to a lower version and see if it comes in correctly for you.

AC1021 - DWG AutoCAD 2007/2008/2009
AC1024 - DWG AutoCAD 2010/2011/2012
AC1027 - DWG AutoCAD 2013/2014/2015/2016/2017
AC1032 - DWG AutoCAD 2018/2019/2020/2021/2022/2023


Hey David.
Thanks for the response. Sadly I have tried all the different version with no luck. This just started after the upgrade. Very weird. I wish I could roll back to the previous version.

Hi Richard,

I can’t comment on the potential bug you are experiencing. But you can roll back to a previous version

Yea, tried some of my own dfx and did the same as your that had circles.

Interesting. So it’s not just me.
It’s looking more like a bug then. I did come up with a work around. I can import it into another drawing package and then export it again. This then imports into Lightburn just fine…why I have no idea. But I might roll back just the same.

Update I rolled back to 11.04 Which I think was the last version before I upgraded and the import works fine. So me thinks it’s a bug.

Thank David for the link for the back leveled version. Thank you the other David for giving it a try.
Suddenly I think I need to change my name to David. lol

If you’re willing to share the DXF file I’ll try it on mine. If I can reproduce the behaviour here I’ll relay it to the testing team.

Were you on Win 10 or Win 11 when it happened?

Hey good morning John.
This is the file.
RG270 New Design Cockpit.3.dxf (110.7 KB)
This was the result.

Another chap tried and got the same result.
It was on a Windows 11 machine…grrr…windows 11.
Thanks for looking into it.

I can confirm this, in LightBurn I have the holes at the left as you, in Fusion360 it imports as it should.

Thanks Melvin.
I appreciate you checking …


This is a new bug, introduced by adding code to handle imprecision errors caused by extremely large offsets in the contents of a DXF file (like having a file modeled 2 miles off the page), interacting with ‘negative extrusion’ values.

I’ve found & fixed the offending code, and it’ll be in the upcoming patch.


wa hooooooo.
So I wasn’t drunk…not that I drink hahaha.
Thanks Oz I appreciate the update.

1 Like

when u drew the design, did u save the whole as a group ??, if not then return back, flip the design, make the group and flip it where u wnt it.

Hey Oz.
Has the patch been released or is it now in the 12 code. I keep seeing the notice to upgrade every time I start Lightburn. But I don’t want to do the upgrade if that DXF bug is in the code still.

No hurry just curious.

There are a few DXF fixes in our latest patch release you can read about here, prior to updating.

Thank you Rick
I will get upgraded then. Wa hooo…loven this software

1 Like

Hey Rick where do you find patches. Sorry I am new to the software so not sure where everything is yet.
Edit: never mind…I found it

1 Like

For others that may find this post, in LightBurn, select ‘Help’ → ‘Check for Updates’. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.