Difficulties in connecting to my laser Creality Ender 3D printer with Laser engraver)

Hi there… newbie question here…
I have 2 laptops at my disposal, one MacBook Pro (Apple Silicon) running Ventura 13.2.1 and can’t connect to my Creality Ender 3S1 (3D printer) with a Laser Engraver unit attached. In Lightburn it simply doesn’t connect. I’ve tried installing the CH34x driver but I have the feeling this driver doesn’t like either 64bit, or Apple Silicon or Ventura, for I can’t seem to get it working (in /dev/tty* I can’t see a driver/COM port) …

So I switched over to an ThinkPad running Ubuntu (LTS 22.04.2) and if I switch on the laptop and printer/laser, I can actually read out my device settings (It comes up with GRBL-M3 (1.1e or earlier)). But then, whatever I do, I see the Laser being disconnected, right-click on device gives me the "waiting for connection… Port failed to open - already in use?)
I can disconnect the USB and look at dmesg in the linux terminal, and see an (other0 USB port being pointed to the CH341-uart, and then select that port in the dropdown and it might work ones, but than I got back the error… Any clues?

I’m not sure that LightBurn will directly connect to that laser - I don’t think the Creality controller provides a GRBL interface for that?

In LightBurn, if you choose the Marlin device type, and ‘Save GCode’ file to the printer’s SD card with a .gcode file extension, you should be able to select and run that file from the printer controls.

Thanks for the answer! and yes, when I save the code to an SD card it runs! That said, ideally it would be great to have it controlled from the laptop. And it worked! Once!
I was able to control the laser from Lightburn, so the electrons were running in the right direction, but after the testrun all was disconnected with that error message…

That’s interesting that it worked briefly - maybe try again with the Marlin device type rather than the GRBL-M3? And set the ‘Baud Rate’ to 250,000 and ‘S-value max’ to 255.

I really appreciate your thinking along… I was getting more and more disappointed to get it to work…

What also puzzles me, is that Lightburn communicates with the laser if I choose “Find My Laser”…

I’ve looked up the baudrate and S-value to 255. It was set that way, and didn’t change it…

I also started Lightburn as root (sudo) for Linux can sometimes be funny with access to USB devices. When I started Lightburn (from the command) I saw these messages on the terminal:

QObject::killTimer(): Error: timer id 22 is not valid for object 0x7ffcbe231450 (LicenseDialog, LicenseDialog), timer has not been killed
QMetaObject::connectSlotsByName: No matching signal for on_lvDevices_rowsMoved()
Found port: PID 7229 VID 32902
Manufacturer: ""
Product: "" on "ttyS4"
attempting connection... 115200, DTR setting: false
Port open succeeded
Wait for initial response...
$i response
Found port: PID 29987 VID 6790
Manufacturer: "1a86"
Product: "USB Serial" on "ttyUSB5"
attempting connection... 115200, DTR setting: false
Port open succeeded
Wait for initial response...
echo:Unknown command: "�?��>z�����������������������������������������������������������������������������������������"
$i response
echo:Unknown command: "$i"
echo:Unknown command: "$c"
echo:Unknown command: "$c"
$$ response
echo:Unknown command: "$$"
Vend: 6127 Prod: 4099
Vend: 6790 Prod: 29987
Vend: 32903 Prod: 36
Vend: 7531 Prod: 2
Vend: 1266 Prod: 45601
Vend: 2652 Prod: 8575
Vend: 32903 Prod: 36
Vend: 7531 Prod: 2

Is that of any use to solve it?

Ok, yeah, it looks like the commands LightBurn is sending down the wire are not being recognised by the controller which will be expecting a different kind of “Marlingo” - I’m not personally that familiar with these Marlin setups, but I suspect that supplying a file rather than a direct stream of instructions enabled a smoother and faster response from that controller.

If you enter the command M115 into the LightBurn console, what response do you get?

hmmmm. intersting, indeed!

Looking at the report in more detail, I spotted the baudrate as 115200, so out of interest I changed the baudrate, and it seems it is more consistent… So, progress!

If I run the M115 command I get:

FIRMWARE_NAME:Marlin V3.0.4_C (May 6 2022 16:21:00) SOURCE_CODE_URL:github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:Ender-3 S1 EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff

can you explain wat Marlin is, actually? Is it the type of controller, firmware or…?

It’s the firmware that’s loaded on the microcontroller (STM32F4 chip for you), on the printer’s main circuit board, in your case it’s “Marlin V3.0.4_C”.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.