Difficulty communicating with laser

Now that I’ve everything installed, LB couldn’t find my laser (which it did last time I did the install ) I’ve manually added the machine. But it’s not communicating.
Machine is connected via UsB
What am I missing?

You should not need to discover ever again. You may need to select the correct port, click drop-down to the right of the ‘Devices’ button.

We are having same problem but no port options are in the port drop down menu. We had to manually add ours and still no connection

I responded to you, please see here: Changing Computer - #2 by Rick