Diode and crosshair alignment

at home postion

how do i get the diode to align with the cross hairs on screen showing location?


Perhaps the Click to Move tool over in the left column of icons does what you want.

It automatically shuts off after 10 seconds, so you don’t inadvertently move the laser head long after you forgot you clicked on that tool. :grin:

to align the diode with the “small location crosshair” at the top left corner of the left earing?

i am toggling the diode down from top left “home position”. it is not engraving where you see the crosses. it is engraving left as where you see the laser postioned in the image above. so technically, the small location cross hair is at the bottom right corner when it should be at the top left i presume. asking how to fix this kind of offset.

zoomed view (crosshair top left of left earing)

Ah! I completely misunderstood.

The “crosshair” you refer to is the visual grid LightBurn puts on its workspace, corresponding to distances from the origin.

The term “crosshair” usually refers to the lines following the mouse cursor around the screen. I have full-screen crosshair mode turned on to make them more visible.

Making the physical laser spot align with the LightBurn grid requires several steps, starting with accurately homing the laser so the controller knows where the laser head is. How that works depends on whether the machine has homing switches or not.

I must bow out at this point, because I don’t have experience with an XTool D1 laser. Other folks, notably @berainlb, know them better and should have relevant advice.

@berainlb has assisted me before, was a lot of help. thanks!

I’m not sure if I understand the issue and I suspect this is not actually about crosshair and diode alignment.

Is the question about why the red laser is not pointing to the top left of the material even though the “last position” marker is show the laser as positioned there?

If so, I suspect this is more of an issue with camera alignment then it is with relationship between laser diode position and last position marker.

If you were to burn those crosses would they be placed perfectly on the material?

If not, I’d suggest going through camera alignment again scaling the target markers as large as will reasonably fit in your laser.

the issue was there before camera installation, I’m just utilizing the camera view for reference.

No the crosses would not be, i have already ran a test pass and it burns to the left of the earrings. where the diode is located in image above.

You should be able to address this by adjusting the values of the pointer offset in Edit->Device Settings.

Try this:

  1. Get some sacrificial material and place on bed
  2. In LightBurn design a small mark or X shape that will engrave the material
  3. Switch to Current Position start from mode in Laser window
  4. Align and burn the mark
  5. Use “get position” in Move window to determine and make note of current laser position
  6. Use jogging controls until crosshairs overlaps the engraved mark perfectly
  7. Use “get position”
  8. Calculate difference between first and second get position results
  9. Adjust pointer offset values based on current difference in values
  10. Repeat test to confirm accuracy. Adjust as necessary.

Instead of using get position you could just measure the location difference. Your call.

Let us know if this addresses the issue.

If you are having alignment problems with small media like that, put some heavy card on the bed, cut out the shapes, then put your media in the cut outs.

I will try this. Machine just now started forgetting text. I have not done the process above… has never done this. any ideas?

I don’t understand what this means. Can you elaborate? What are you trying to do, what do you expect to happen, what happens instead?

it was engraving them out of order for some reason but it completed all text.



Thank you. Yes this fixed the issue.

Glad that worked.

Note that the Solution marker should be set on the post with the solution itself. This helps folks find the solution when reviewing Topics.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.