Diode laser not completing cuts

I know some other users have been running into this issue where cuts aren’t completing and a little space is left or a gap in the cut. For me, it happens at the end of the cut. As far as I know nobody has found a solution, but I wanted to re-post the issue because I have a bout a week left on my light burn trial and if there’s no solution, then I don’t really see the point in buying it. The only way I’ve gotten a cut to work so far is using a lower power on the laser and making it do two passes so that it cuts over the gap on the second pass. It seems to work OK but it just takes longer to do the cut. Anyways, if anyone has anything else to suggest, I am all ears. thanks in advance

Can you provide the following:

  1. upload the .lbrn file used to create the circle in the photo
  2. For the circle, go to File->Save Gcode and save to a file with .txt extension and upload here

Check you do not have Tabs set to ON

ive tried tabs off/on and many other setting adjustments, so far no dice

ok here you go, im new to g-code but i think it saved properly:
circle.txt (2.7 KB)

The code looks fine.

There are a couple of possibilities for what’s going on:

  1. Your speed setting is too high and variable power is adjusting the power down enough that it’s cutting off entirely. Your speed setting is around 5000 mm/min which is likely way higher than you’re actually moving. You can test to see if this is the problem by enabling “Constant Power Mode” in your cut setting. If this eliminates the gap then I’d suggest dramatically lowering the speeds in which case power will be modulated more in line with what would be expected.
  2. You have mechanical backlash in your system and the ends of the circle are just not connecting together because of it. The gap seems bigger than I would expect in that scenario but I wouldn’t rule it out.

I’d suggest checking in the order that I’ve listed.

Yeah that speed setting was way too high, I always adjust speed and power settings, I ended up just taking a quick video of some tests I did, if you have a couple minutes and feel like watching, maybe something will stand out to you,

Try enabling “Constant Power Mode”. If that leaves you still with the small gap then it’s very likely due to backlash.

You can test this by enabling “Hide backlash” in Optimization Settings. If that allows for a complete cut then it’s worth spending some time to really hunt down any source of backlash in your system. Stepper to pinion gear connection is a very common source of backlash if not properly secured. Check any linkage points. Based on the video I’d focus first on the Y axis. You could test for this by doing scan tests with a filled rectangle with large line interval (~1mm). Do this horizontally and vertically bidirectionally. Any misalignment of the scan lines is likely due to backlash.

Really appreciate the feedback, I’m gonna try those asap and see what I find.

quick update, I don’t see a lot of adjustment options with the belts, they’re just held in there with screws, on the stepper motor gear there are a couple Allen bolts, do those look like they would adjust belt tension? I have 3D printers, but the adjustment was different for them. I’ll add pics and another video link on what’s going on.

You’re not necessarily looking to adjust bolt tension. You want to eliminate any wasted movement. So basically any movement from the stepper motor should be delivered without loss down to the next component of the motion chain. If there is any lost motion back and forth on the shaft then that will result in backlash. Make sure the grub screw is well secured to the flat of the shaft. There may also be another screw located at a different angle that you can also secure. Check every linkage down the chain of motion from stepper all the way to the laser module and make sure there’s no wiggle back and forth at any component.

Constant Power Mode is found in the Cut setting for a given layer.

Based on your video it’s very likely you’re dealing with backlash. I suspect the reason you’re getting variance in gap between runs is because of the starting position of the laser. If you run back-to-back runs with the same starting position the gap should look about the same if the theory holds.

I’d suggest running the filled scan test to isolate X vs Y axis and to confirm backlash is visible there. If the test comes back negative then it’s possible there’s something else going on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.