Direction and inversion

I tried setting up my Sculpfun s30 (5.5?)and burning my name .
using windows 11
using the direction arrows all is off 90 degrees (up is right,right is up,left is down,and down is left). Name was also spelled backwards in the burn but obviously on my laptop correct.

You probably switched the motor cables (the x motor is the one at the linear rail, the y-axis is the one driving the whole gantry), because you can’t flip the axis in software.
Have a look here to understand the coordinate systems: Coordinate systems & workpiece alignment - Diode Laser Wiki
And further, check all the guides here: Quick Start & Overview - Diode Laser Wiki There are also articles on how to set up LB correctly.

Thank you so much for your help! After work today I will try switching them. That might explain the grinding noise sometimes.

All I can guess is that the labels were put on wrong from the factory. Believe me I thought of that.The link you sent me shows Y being connected at the bottom left and runs up and down , north and south.
the X is higher and on the left but runs the left right , east west.
I have them plugged in to the matching molex coming out of the BRAIN lol.
Im going to flipflop them just to see if it works.

Sorry but I put the X on the Y and Y on the X and went into MOVE again and it does THE SAME THING. HHEELLPP!!!

Rather than the wires do I have to switch the tiny boards?(things with the bumper stops)

First, make sure that the arrows move correctly. Next is to check the homing function. But first we need to make sure that if you press left, the laser moves left. Be aware that the small control box is mounted front-right. As a reference.

I am going to uninstall and start over

Hi, I too have the same problem, did you solve it? how did you do?

Please describe the problem and show your firmware settings.

problem solved for the movements and the wrong engravings, I inverted the X and Y cables inside the controller of my sculpfun s30 5w, and now the movement is correct. the problem of homing always remains, by clicking home the laser stops.

Do you get any console message? You should, I guess.

I purchased another one and it works PERFECTLY, ty though