Disable Air on Travel

Is it possible to disable air assist when making travel moves?

I’m cutting delicate shapes and the air just blows everything around as it passes over previous cut shapes.


1 Like

For patterns cut from paper or similar light materials, that will likely happen even with low-flow assist. It may be better to add (very small) tabs to the pattern (so nothing comes loose), then resign yourself to weeding the result with tweezers and a scalpel.

You can add a flow control valve to reduce the air flow or plumb in a pair of solenoid valves to switch between high / low / no flow; searching the forums for “air assist” will bring up many posts.

The least fiddly alternative may be the Cloudray version of Sadler’s Ultimate Air Assist hardware:

Which is dramatically less expensive through Amazon:

I built a similar design from common parts, including a flowmeter:

Works fine, but I still use tabs even for the lower flow rate …

As @ednisley noted, there are a lot of variations on the air assist… I use one that is similar to most in that it uses the ‘status’ and ‘wind’ sinks of the Ruida.

These are the only outputs that give you the information on what’s going on within the Ruida.

An old version of RDWorks has a ‘Blow’ option that can control the air assist only when it’s lasing. You may be able to find that out there somewhere.

The drawback is that the solenoid is constantly turning on/off and consequently is annoying and has a shorter solenoid life… It can’t really keep up with the laser… most people are searching on how to turn this off not enable it…

Here’s my ‘air assist’ control…

Good luck


Thanks @ednisley and @jkwilborn for taking the time to give your thoughts and feedback. I really appreciate it!

I’m actually cutting thin wood so I can’t turn the air assist down. I probably don’t need every travel move to have air assist off, just the problematic ones.

Is it possible to manually edit .rd files? If this were gcode I would just edit the file and send a command to turn off air assist when I need to, but it appears .rd files are a binary format of some kind.

And resolutely undocumented, so it’s a blob passed between LightBurn and the Ruida controller, with none of the fine-grained control available from G-Code.

Tabs will be your (awkward and inconvenient) friend …

Depending on the firmware in your Ruida, it might be possible. If you have a 6445 or later, there’s a setting called ‘Air Assist Mode’ in the machine settings. The default is “on/off by layer”, but you can also choose “on/off with laser”, which is what you’re asking for.

As Edinsly noted, we don’t have the ability from software to directly control the behavior of the air assist on DSP controllers.

I tried that once and wow does the poor solenoid valve chatter!

IIRC, in that mode the Open and Close times apply to every laser-on vector:

However, adding enough time to let the solenoid cycle properly slowed the whole thing down beyond belief, so that didn’t help.

1 Like

Unfortunately mine does not seem to have that setting.

I had no idea the controller was so locked down. Is there a different controller that would give us more control?

I was able to mostly get around the issue by manually setting the cut order and by setting some 0% power layers with air-assist turned off that move the head to the next location. It’s a hack but seems to work.

One of the threads on the Ruida mentioned that certain versions of RDWorks will allow you to change this… I don’t use Windows, so I can’t really say I’ve done it…

Most of the people that have tried this and like @ednisley have found it not an advisable option…

I’d hate to see you spend money to find it isn’t going to work as expected…

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.