Disable Steppers

I have a Chuck style rotor. I would like to Disable my stepper motors for etching mugs in order to rotate the mug and set the start position of the process. Then re enable the steppers and use “current position” as the “Start From” setting.
Is this possible?
I have a Ruida 6442 controller

I don’t think a way to do it from the software or ruida controller.
Put a switch on the power lead to the stepper driver?

G-code for disable steppers is M18 enable is M17. I just figured it would be a thing.

Good point. I know that works on CNC-3018 with GRBL controller. I don’t know if it works on the GRBL diode lasers, I’m not in a position to check, although that doesn’t help you much :upside_down_face:

Hopefully Oz or someone will chime in. I don’t think it’s “a thing” for Ruida controllers.
If it’s possible, I’m interested. I just use the jog buttons on the controller to get my rotary aligned where I want it.

If it is not possible I will need to get a lot better at jogging. Seems like I’m always overshooting.

Console! And I don’t mean that to console you, but command line ‘nudging’ is the ticket for me.

Hit the “speed” button on the controller and turn it down. It’ll jog slower.

Per your advice I set it to 10mm/sec. Accurate enough without being to painful.

luckily the Ruida does not use G-code

Can you explain that further? Maybe provide a link to a good discussion on it?

Good to know, first foray into this. Stepping up from 3D printing.

By ‘nudging’, I mean, giving a series of commands in the console to iteratively move smaller and smaller steps in G91 mode until you’ve reached the position you want. Generally it will only take 3-4 commands to get a very precise position (if you’re good at guessing).

Unfortunately (for you), this technique won’t work in your case. As @Enno points out above, Ruida does not use G-Code. I was not aware of this, I apologize for the misguidance.

I found the source of my original confusion. Before I received my Laser I watched a lot of videos. It turns out one of the tutorials on engraving tumblers was based on K40Whisperer. That has a button to disable the steppers.

Ruida controllers don’t use GCode, so they can’t use the console either. By adjusting the speed or distance values in the Move window (or on the controller itself) you should be able to jog where you need to go pretty easily. I’ll often set my movement speed on the controller to 111 mm/sec, so I can quickly toggle between 111 and 011 (by just changing the leading digit), which lets you move quickly to a good spot, then much slower to fine tune it.

1 Like

Heh… I use 99 & 09. :slight_smile:

You can set the console to jog down to a mm at least. I haven’t tried less, but Oz has a great idea with the 111 and 011…