Distorted Image Sends Wonky From One Laptop, Works Perfect on Another

I apologize to start, I’m new with the technical speak, but will try to be as descriptive as I can. I am running Lightburn v.1.0.06 on a Windows 10 HP Pavilion 15. I connect to the machine (Rabbit SD-60-6040, Ruida 644XG controller) via USB. The design file appears fine in Lightburn, but the image sent to the machine ends up missing pieces and adding lines in wrong places. It has to be a setting on my laptop because if I put the file on a flash drive and transfer it to my sister-in-law’s laptop (a slightly older HP Pavilion running an earlier version of Lightburn, 0.9.19, it has no issues sending a clear image. I have matched my settings and device settings to her laptop. Machine settings work fine for her so, I don’t even want to mess with that. I can send it 5 different times, and end up with 5 different messed up images, but ever once in a while I’ll get lucky and it will send correctly. I’ve tried updates, I’ve tried uninstalling and reinstalling, I’ve tried previous versions, I’ve tried saving as a .lbrn2 file (default) or .lbrn legacy file (this is what my sister’s laptop runs, the older version of Lightburn can’t open lbrn2 files. Ideas for what to try next? Screenshot shows file in lightburn, photo is dark but shows screw ups on the laser screen, circled in red so you don’t have to hunt for differences.

This one is a bit odd. Let me ask some clarifying questions.

  1. Where was the design created? On your computer or on your sister’s or elsewhere?
  2. You list that you’re using version 1.0.06 of LightBurn but your screenshot is of 1.0.04. Can you clarify?
  3. When you say it works fine from your sister’s laptop are you sending to the same physical laser or to a different laser?
  4. Are the issues you see always immediately apparent in the Ruida display? Do you know if the artifacts are carried into the actual burn?
  5. Does the Preview in LightBurn look correct or does it match the Ruida display?

Are you able to share the .lbrn2 file here? There maybe something in the design that’s complicating things.

  1. The original design is from Etsy, and was just one of several Etsy/designbundles files that end up with the same issue, so it can’t be this specific file. Though maybe it’s because it’s a downloaded file? Svg, pdf, dxf, if I can import it, it probably ends up with wonky parts on the laser but not in the program. But either way, if the file can be imported to lightburn on a different device, or similarly, the saved lightburn file can be opened on a different device and be sent to the laser to burn successfully, it’s unlikely to be the file. I’ll try a few files I’ve created tomorrow to see if it cooperates. It probably breaks filesharing rules to upload a purchased file. If what I created ends up not working, I’ll share that.

  2. Screenshot was 1.0.04, had the issue at least then, if not before that. I don’t remember what the initial downloaded version was, but I’ve had the issue from the beginning. I updated to .06, but no change to the problem. Some files might work. Most tend not. Or I can send it half a dozen times and get lucky. The lines appear in different places with each send to the laser. Apparently I didn’t screenshot it after updating. Its been a few days since I’ve run anything. I can try it tomorrow to get a more up to date shot. Why she doesn’t update hers, I don’t know. (She probably doesn’t want it to do what this is doing).

  3. Same file, same laser. Different computer is all. My house is too tiny for a machine that size, so it is installed in her basement. (Vented, cooled, and cleaned properly. I’m so jealous :joy: I have to drive 20 min to their house to do anything)

  4. Flaws are immediately apparent on the controller screen, sometimes small and hard to catch. It does carry over to the burn. Though I only tested that theory once because I didn’t want to waste material.

  5. Lightburn preview looks correct. It’s like something is lost in translation between the computer and the laser.

I’ll try something in RDWorks (which is so horribly user-unfriendly) to see if it’s the laptop, or program. I’m going to try to install Lightburn on my Surface tablet in the morning, and try it as well.

Okay, thank you for the thorough response and working through every question.

All of what you’ve said is indicating to me that there’s an interface issue with your computer and the Ruida controller. Probably something on your specific computer since it works with your sister’s.

If you do get LB installed on the Surface I bet things will work.

Similarly, I don’t think it’s a problem with your LB installation because of a few things:

  1. The files save and work on your sister’s computer
  2. Preview looks correct.

I’m going to suggest a handful of other things for you to try to confirm this later on.

As for the primary issue I suspect a problem with your USB port. I assume you’re using the same cable that your sister uses? If so, the cable is likely fine. If not, could also be a cable issue.

Try these various troubleshoot strategies:

  1. Try plugging into a different USB port on your computer if you have one and try to send a file for preview. If this works, then isolated to a single USB port.
  2. Confirm that the Ruida device type has been setup the same way on your computer as your sister’s. I assume you’re using either Serial or Packet USB.
  3. Try pushing the Save RD File button in your Laser window and save the file to a known location. Then try the following 2 things:
    3a. Try opening the RD file again in LightBurn. You won’t have all the same information as the original LightBurn project file but all the elements should be there. If not, then this is a problem in LightBurn. If it looks correct, then this reinforces my theory.
    3b. Take the same save file and copy the file to a USB thumb drive. Plug that into the Ruida and preview the file. If the preview looks correct then again, reinforced my theory.
  4. If you are able to connect Ruida to ethernet you could try switching to ethernet
  5. Alternatively, you could use the LightBurn Bridge to make the system wireless.

4 and 5 assume that you can definitively prove it’s a problem with the USB connection which step 3 should tell you.

So, I sent a 2 layer file (road map with river, pulled from Google maps) that I created. Final product at the bottom. Sent the road part first, worked perfectly. Sent the river part second, appeared on the laser as a line (see photo), error froze the machine. Communication error when selecting file, froze completely, repeatedly. Couldn’t select files to run, couldn’t delete files from the machine or from the computer. It was stuck on the river file, and I couldn’t press buttons to run/delete/anything. Error timeout prompted press esc, and then would start the cycle all over. (Timeout, that problem solved itself below)

  1. Usb port doesn’t seem to matter (great suggestion, tried that already), both make the “ding ding” connection noise, but I’ve struggled with both of them.
  2. I used serial/usb. She didn’t remember which she used. I’m guessing serial/usb, it was the easiest but who knows.
    3.(3a) I don’t know why, but this solved my communication error/frozen cycle issue. Sending an .rd file this way worked, and then I was able to delete all existing files in the memory off the machine, so it cleared out the corrupted image (which I couldn’t do while it was frozen with communication error issues). Since running the .rd file, and restarting my computer, I have had 0 issues (fingers crossed). Ran several downloaded etsy files, and a couple created files, no issue!
    (3b) Same thing, looks correct.
  3. I’ll save this idea for the future, so far it seems like the USB is fine (hopefully). It won’t need an internet connection, right?
  4. They don’t have access to wifi (which is crazy, but true. Hotspot, which I try not to use up all their data.) so unfortunately, that’s not an option. But that’s ok.
    Final Product (Not anything fancy, but for all the struggles I had, I’m satisfied it cut correctly)

Thanks for the help! Happy New Year!

Awesome map carving! Especially dealing with

So it sounds like you’re back in business but with no absolute clarity on why. I do know that Ruida controllers can exhibit strange issues when its storage spaces gets low. Could have been the issue here. Not sure why it didn’t affect your sister’s computer though. If she was using the play button vs send that could make a difference.

Ethernet connection doesn’t use Internet so you’re covered in that scenario. The hotspot situation sounds like its own little adventure.

Good luck with this. Hope no more issues but circle back if you have something to share.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.