Do not return to start position when job complete


(Jonas) #1

Is there a way to change LB’s behavior so that the head does not return to the starting position once the job is complete.

Specifically I use a rotary exclusively and would like the work not to spin back to the start position after a cut / engrave.


(Rick James) #2

Yes, there is for gcode, DIY type controllers. Disable the ‘Return to Finish Position’ option on the ‘Device Settings’ window, but this is just a guess as you have not provided anything about your controller or firmware and it is not in your profile. :slight_smile:


(Jonas) #3

Hi Rick,

I have a custom dedicated rotary laser using GRBL LPC as a controller, and some K40 parts.

I found the setting but it does not seem to have an effect.


(Oz) #4

It depends on which mode you are engraving in. Absolute Coords mode and User Origin work this way. If you’re using “Current Position” as the start from setting, it has to return to the starting point in case you need to repeat the job.


(Blake Bartlett) #5

Is this changeable? I wouldn’t mind having the option to leave the head where it ends when the job is done. With my Ruida, I can hit esc and the head moves back to where I set the origin anyhow. Plus on jobs I repeat a lot, I have to move the head every time to remove the work piece and put a new one in.

EDIT: Maybe I ought to be using User Origin mode…


(Oz) #6

I can’t affect the end behavior on a Ruida - it’s a controller setting, so you’d need to set that.


(Jonas) #7

Yes can we have this updated on a future version to allow diabled return to finish position under “current position mode” with GRBL / GRBL-LPC?


(Oz) #8

I can, but if you ever interrupted the job you would not be able to re-run it, because your starting point would be lost. If the job completed and you realized that not all of it cut through there would be no way to run the exact same path again, because I would not know where it started.

The simplest way to have it not return to the preset position is to position the laser where you want it to start, click the Set Origin button, and run the job in User Origin mode.