During laser engraving, it suddenly speeds up, then returns to normal

For starters, I have a cheap laser attachment for my Ender3 and am trying to use Lightburn to make the gcode.
The Lightburn software has about 6 seconds towards the beginning part of engraving that it suddenly speeds up. It usually is about within the first minute of engraving, then goes back to normal for the remainder of the engraving.
Could it be I am trying to squeeze too much out of something so inferior(pertaining to engraving machines)?
The default Creality engraving software sucks and wish to really use Lightburn. Any help would be appriciated.

Hopefully you’ve gone through and setup lightburn for your device. It’s doing what it’s told. Somewhere something has told it to speed up.

Most of what you have told us doesn’t really help with the issue.

What is it doing that’s ‘fast’ for 6 seconds? Does it show in the results?

50% of the solution is understanding the problem, which I don’t.

Technically…I had to setup a generic engraver, due to having the engraver not be actually recognised by Lightburn. It is an Ender3 3D printer with the laser engraver attachment plugged into the part cooling fan.Which is why I had Lightburn generate the Gcode for it, then transfer to the Ender3 for engraving
My apologies I am trying to describe it the best way I can. When I set the general speed for the Engraving on one layer throughout the entire session, there is a portion of the Engraving that is missing because it’s moving too fast. Is it safe to assume that having only one layer and not multiple layers and setting a specific speed for that layer that it shall not change during the engraving process. I do understand there is travel speeds that could be different also. But I am referring to the actual engraving speed changing during the Engraving session.

I was hoping there should be a setting that I should specifically look for because I have not found this problem in any of the forums yet.

I definitely heard of baud rate problems if it’s not set correctly and stalling and slowing down but this speeds up…

I hope that adds additional information

Maybe it would be helpful to send a link to the video and see whats happening. Because I really like Lightburn software, but this is holding me at a standstill. Once again. sorry for the lack of information. I am new to laser engraving, but not to 3D printing.

Can you attach some generated GCode here to look at? There should only be one feed rate set for G1 moves, and one for G0 moves.

If the engraving is dithered, and you’re trying to run too fast, it’s possible that the early part of the job is simple (relatively few commands, spaced out) and the controller is able to process those at the requested speed, but then later the job gets more complex (lots of small dots) and the controller can’t maintain the requested throughput. That’s a guess, but it’s possible.



https://drive.google.com/file/d/1uNJvz963LT4rCDgnXz4XYaMC8qkPNSup/view?usp=sharing

Narrowed it down to the Machine board. More I engrave with the same gcode, the different it gets. I assume it is because it is not designed to be used as such, therefore the gcode I am asking it to do, not 100% compatible with Creality Ender3 v1 board. I appreciate your help pushing me to get more information, otherwise I may not have exactly pinpointed the issue.
Any budget laser engraver you reccomend that is Lightburn compatible? I have wanted more since the first week of dabbling with this 500mw one but am on a budget of bout $300.
Here is the gcode to verify:

; LightBurn 0.9.24
; Marlin device profile, absolute coords
; Bounds: X4.3 Y5.27 to X40.79 Y15.95

;USER START SCRIPT
G0 Z105 F3000
;USER START SCRIPT

G21
G90
; Cut @ 175 mm/min, 100% power
M9
M106 S0
G0X24.71 Y73.44 F0
; Layer 1
M106 S255
G1X26.07 F175
G1 Y82.56
G1X29.49
G1 Y83.78
G1X21.3
G1 Y82.56
G1X24.71
G1 Y73.44
M106 S0
G0X31.06 Y73.44 F0
; Layer 1
M106 S255
G1X38.77 F175
G1 Y74.66
G1X32.43
G1 Y78.18
G1X38.14
G1 Y79.39
G1X32.43
G1 Y82.56
G1X38.53
G1 Y83.78
G1X31.06
G1 Y73.44
M106 S0
G0X40.51 Y75.45 F0
; Layer 1
M106 S255
G1X40.65 Y75.15 F175
G1X40.83 Y74.87
G1X41.03 Y74.6
G1X41.26 Y74.35
G1X41.66 Y74.03
G1X42.1 Y73.77
G1X42.57 Y73.56
G1X43.06 Y73.43
G1X43.59 Y73.34
G1X44.12 Y73.28
G1X44.65 Y73.27
G1X45.18 Y73.29
G1X45.69 Y73.37
G1X46.18 Y73.5
G1X46.63 Y73.67
G1X47.12 Y73.94
G1X47.55 Y74.28
G1X47.91 Y74.7
G1X48.2 Y75.18
G1X48.34 Y75.56
G1X48.43 Y75.96
G1X48.46 Y76.36
G1X48.43 Y76.77
G1X48.35 Y77.15
G1X48.22 Y77.5
G1X48.03 Y77.83
G1X47.84 Y78.08
G1X47.62 Y78.3
G1X47.38 Y78.49
G1X47.12 Y78.66
G1X46.81 Y78.83
G1X46.49 Y78.97
G1X46.16 Y79.09
G1X45.82 Y79.19
G1X44.92 Y79.43
G1X44.01 Y79.64
G1X43.41 Y79.8
G1X42.82 Y80.01
G1X42.57 Y80.12
G1X42.35 Y80.28
G1X42.17 Y80.47
G1X42.05 Y80.69
G1X41.97 Y80.93
G1X41.95 Y81.2
G1X41.98 Y81.47
G1X42.06 Y81.73
G1X42.2 Y81.97
G1X42.38 Y82.18
G1X42.58 Y82.33
G1X42.79 Y82.46
G1X43.01 Y82.56
G1X43.25 Y82.63
G1X43.78 Y82.72
G1X44.31 Y82.75
G1X44.84 Y82.72
G1X45.37 Y82.62
G1X45.66 Y82.53
G1X45.94 Y82.38
G1X46.18 Y82.19
G1X46.39 Y81.97
G1X46.54 Y81.75
G1X46.66 Y81.51
G1X46.75 Y81.26
G1X46.8 Y81.01
G1X46.84 Y80.77
G1X48.15 Y80.87
G1X48.11 Y81.31
G1X48 Y81.73
G1X47.85 Y82.12
G1X47.64 Y82.49
G1X47.37 Y82.84
G1X47.05 Y83.14
G1X46.69 Y83.39
G1X46.29 Y83.58
G1X45.84 Y83.74
G1X45.35 Y83.86
G1X44.82 Y83.93
G1X44.29 Y83.95
G1X43.76 Y83.93
G1X43.28 Y83.87
G1X42.81 Y83.76
G1X42.37 Y83.6
G1X42.13 Y83.5
G1X41.9 Y83.37
G1X41.69 Y83.22
G1X41.49 Y83.06
G1X41.31 Y82.87
G1X41.15 Y82.67
G1X41 Y82.45
G1X40.88 Y82.22
G1X40.74 Y81.86
G1X40.66 Y81.49
G1X40.63 Y81.11
G1X40.65 Y80.76
G1X40.72 Y80.43
G1X40.83 Y80.11
G1X40.99 Y79.82
G1X41.2 Y79.54
G1X41.45 Y79.29
G1X41.83 Y79.01
G1X42.25 Y78.78
G1X42.99 Y78.51
G1X43.75 Y78.3
G1X44.7 Y78.07
G1X45.66 Y77.8
G1X45.94 Y77.71
G1X46.2 Y77.59
G1X46.46 Y77.44
G1X46.7 Y77.27
G1X46.89 Y77.06
G1X47.03 Y76.81
G1X47.12 Y76.54
G1X47.14 Y76.25
G1X47.11 Y75.95
G1X47.02 Y75.67
G1X46.88 Y75.4
G1X46.68 Y75.17
G1X46.47 Y75
G1X46.24 Y74.85
G1X45.93 Y74.72
G1X45.61 Y74.62
G1X45.29 Y74.55
G1X44.96 Y74.51
G1X44.55 Y74.49
G1X44.15 Y74.51
G1X43.75 Y74.57
G1X43.35 Y74.67
G1X43 Y74.8
G1X42.66 Y74.97
G1X42.38 Y75.15
G1X42.14 Y75.37
G1X41.95 Y75.6
G1X41.79 Y75.88
G1X41.68 Y76.17
G1X41.58 Y76.52
G1X41.52 Y76.88
G1X40.23 Y76.76
G1X40.25 Y76.43
G1X40.31 Y76.09
G1X40.39 Y75.77
G1X40.51 Y75.45
M106 S0
G0X53 Y73.44 F0
; Layer 1
M106 S255
G1X54.37 F175
G1 Y82.56
G1X57.79
G1 Y83.78
G1X49.59
G1 Y82.56
G1X53
G1 Y73.44
M9
M106 S0
G90

How did you ‘transfer’ it to Ender3?

You should be able to do all of this through LightBurn via your controller connection.

Watching your video, the laser is firing (can’t tell what level) but it just speeds around it.
When you watch this on the preview does it speed up also? You can set the preview speed slow so you can watch it in detail.

Also it’s inconsistent, true? That indicates a hardware failure. Same file being run with different results has to be hardware. Give me something to make me think different, please… hate to be the bearer bad news.

I would say its even possibly marlin version issue with that type of gcode that was written by Lightburn. Even though 3D printing seems to work just fine, along with the gcode written by CrealityWorkshop (the software that generates gcode for that exact type of board and marlin for laser engraving).

To be honest, I even had worse issues laser engraving using the newer 32bit creality board. So I switched back to marlin 1.0…(what the Manuf said will work). I heard marlin 2.0 gives issues with laser engraving

The Lightburn preview is the correct speed, it does not speed up, and correct z height for the focus of laser(105mm which I could change at any time)
I transfered the gcode to the Ender 3 with Repetier Host( I have a few 3D printers attached to my computer with it). But could not connect to Lightburn possible because repetier was already using the com port…lol

Here is the Gcode written by crealityworkshop. It is definately different, but the same per say. didnt copy all of it though… too long

;BingoStart
G90
G0 F3000

G0 Z105 F3000; Z HEIGHT FOR LASER(100 + PART THICKNESS)
G0 X17 Y68;BUILD VOLUME DATUM ZERO
G92 X0 Y0 Z0;SET ABSOLUTE ZERO
G0 X37.6727 Y0.890909
M106
G1 F360
G1 X37.6727 Y0.890909
G1 X32.2 Y0.890909
M107
G0 F3000
G0 X32.2 Y0.890909
G0 X31.0545 Y1.01818
M106
G1 F360
G1 X31.0545 Y1.01818
G1 X39.2 Y1.01818
M107
G0 F3000
G0 X39.2 Y1.01818
G0 X39.9636 Y1.14545
M106
G1 F360
G1 X39.9636 Y1.14545
G1 X29.9091 Y1.14545
M107
G0 F3000
G0 X29.9091 Y1.14545
G0 X29.2727 Y1.27273
M106
G1 F360
G1 X29.2727 Y1.27273
G1 X40.9818 Y1.27273
M107
G0 F3000
G0 X40.9818 Y1.27273
G0 X41.4909 Y1.4
M106
G1 F360
G1 X41.4909 Y1.4
G1 X28.5091 Y1.4
M107
G0 F3000
G0 X28.5091 Y1.4
G0 X27.8727 Y1.52727
M106
G1 F360
G1 X27.8727 Y1.52727
G1 X42.2545 Y1.52727
M107
G0 F3000
G0 X42.2545 Y1.52727
G0 X42.6364 Y1.65455
M106
G1 F360
G1 X42.6364 Y1.65455
G1 X27.1091 Y1.65455
M107
G0 F3000
G0 X27.1091 Y1.65455
G0 X26.7273 Y1.78182
M106
G1 F360
G1 X26.7273 Y1.78182
G1 X43.4 Y1.78182
M107
G0 F3000
G0 X43.4 Y1.78182
G0 X43.7818 Y1.90909
M106
G1 F360
G1 X43.7818 Y1.90909
G1 X26.0909 Y1.90909
M107
G0 F3000
G0 X26.0909 Y1.90909
G0 X25.8364 Y2.03636
M106
G1 F360
G1 X25.8364 Y2.03636
G1 X44.4182 Y2.03636
M107
G0 F3000
G0 X44.4182 Y2.03636
G0 X44.6727 Y2.16364
M106
G1 F360
G1 X44.6727 Y2.16364
G1 X25.2 Y2.16364
M107
G0 F3000
G0 X25.2 Y2.16364
G0 X24.8182 Y2.29091
M106
G1 F360
G1 X24.8182 Y2.29091
G1 X45.1818 Y2.29091
M107
G0 F3000
G0 X45.1818 Y2.29091
G0 X45.4364 Y2.41818
M106
G1 F360
G1 X45.4364 Y2.41818
G1 X36.5273 Y2.41818
M107
G0 F3000
G0 X36.5273 Y2.41818
G0 X33.4727 Y2.41818
M106
G1 F360
G1 X33.4727 Y2.41818
G1 X24.3091 Y2.41818
M107
G0 F3000
G0 X24.3091 Y2.41818
G0 X24.1818 Y2.54545
M106
G1 F360
G1 X24.1818 Y2.54545
G1 X31.9455 Y2.54545
M107
G0 F3000
G0 X31.9455 Y2.54545
G0 X38.4364 Y2.54545
M106
G1 F360
G1 X38.4364 Y2.54545
G1 X45.9455 Y2.54545
M107
G0 F3000
G0 X45.9455 Y2.54545
G0 X46.2 Y2.67273
M106
G1 F360
G1 X46.2 Y2.67273
G1 X39.3273 Y2.67273
M107
G0 F3000
G0 X39.3273 Y2.67273
G0 X30.6727 Y2.67273
M106
G1 F360
G1 X30.6727 Y2.67273
G1 X23.6727 Y2.67273
M107
G0 F3000
G0 X23.6727 Y2.67273
G0 X23.4182 Y2.8
M106
G1 F360
G1 X23.4182 Y2.8
G1 X29.9091 Y2.8
M107
G0 F3000
G0 X29.9091 Y2.8
G0 X40.3455 Y2.8
M106
G1 F360
G1 X40.3455 Y2.8
G1 X46.7091 Y2.8
M107
G0 F3000
G0 X46.7091 Y2.8
G0 X46.9636 Y2.92727
M106
G1 F360
G1 X46.9636 Y2.92727
G1 X40.9818 Y2.92727
M107
G0 F3000
G0 X40.9818 Y2.92727
G0 X29.0182 Y2.92727
M106
G1 F360
G1 X29.0182 Y2.92727
G1 X22.9091 Y2.92727
M107
G0 F3000
G0 X22.9091 Y2.92727
G0 X22.7818 Y3.05455
M106
G1 F360
G1 X22.7818 Y3.05455
G1 X28.5091 Y3.05455
M107
G0 F3000
G0 X28.5091 Y3.05455
G0 X41.7455 Y3.05455
M106
G1 F360
G1 X41.7455 Y3.05455
G1 X47.4727 Y3.05455
M107
G0 F3000
G0 X47.4727 Y3.05455
G0 X47.6 Y3.18182
M106
G1 F360
G1 X47.6 Y3.18182
G1 X42.2545 Y3.18182
M107
G0 F3000
G0 X42.2545 Y3.18182
G0 X27.8727 Y3.18182
M106
G1 F360
G1 X27.8727 Y3.18182
G1 X22.2727 Y3.18182
M107
G0 F3000
G0 X22.2727 Y3.18182
G0 X22.1455 Y3.30909
M106
G1 F360
G1 X22.1455 Y3.30909
G1 X27.4909 Y3.30909
M107
G0 F3000
G0 X27.4909 Y3.30909
G0 X42.8909 Y3.30909
M106
G1 F360

had to delete ending…not enough charaters to send

Usually, just post the file, we can look at it if we need to.

I keep going back to the test code you showed in the stills. The T is missing parts and the S, but the E is all there. In your video the E fails and the T worked fine. If you are running the same file and having different results that is usually indicative of a hardware failure.

The lasers on these machines are driven by a PWM signal from the controller. It’s on when the PWM signal is high (usually). Your laser does not seem to go down in power, as if I could tell, but it definitely speeds up.

Being that the preview shows it properly I’d have to go with the odds and past expierence. This stuff has been hammered by a lot of people. This would surely have shown up.

Do you have any other files that are known working? Do they burn properly with anyone’s software?

Yes, running the same gcode file… over and over…different results…wierd eh?

All in All,…yes it burns flawlessly with crealityworkshop program. Unfortunately it is VERY basic. It does not have much for customization. basically customizable with speed only for travels and laser.

If it were hardware, I would also have an issue when 3d printing I would assume.
I already crave a much better engraver, so I will just keep using the default software for now and graduate to a new engraver that is built to engrave out of the box, not built to 3D print out of the box…

I appreciate the help !
I will also be sure to tell my issues for anyone trying to use an Ender3 for engraving and Lightburn…
I really like Lightburn enough to likely purchase now and use with a new and better laser engraver later…
Thanks again !!!

This makes it sound like you have a configuration problem. Did you post the .lbrn2 file of this?

It doesnt matter what I place on the build plate, something on the part always skips a beat, sometimes more than once as seen in video. I will try changing the baudrate in the settings also.

I shall stop pretending and purchase a real laser engraver soon as well.

TEST.lbrn2 (11.2 KB)

Design looks clean and simple. I always cringe when I see 100% power…

These things can be a headache.

We can eliminate hardware, since it’'s operational with other software. I don’t know that equipment.

Have you ever been able to connect to it and completely control it via Lightburn? If that isn’t happening, then we should target that first and remove one more item in the work flow.

I don’t see anything in the Creatlity generated GCode that sets the power of the laser. In LightBurn that’s the M106 Sxxx command, where the xxx part is a number from 0 (off) to 255 (100% power).

It also looks like you haven’t set a ‘Fast Whitespace’ speed in LightBurn - do this in Edit > Device Settings. Marlin firmware doesn’t differentiate G0 and G1 moves like the GCode spec says to, so you have to provide a speed for the G0 moves, and that’s the ‘Fast Whitespace’ speed in this case. The Creality code uses 3000 mm/min for that, so start with that (50mm/sec) and see if that helps. It’s possible that when it hits the G0 commands with F0 it’s getting confused.

I will try that this week. Thanks for the insight!!