Dwell G4 or G04

Will Lightburn run a G4 F5. for stop or dwell before burn. I’m trying to stop some jiggle I’m getting when going from rapid to feed .

It’s not clear to me how you’re trying to use this but LightBurn uses G4 if you enable “Cut through” in the Advanced tab for a Line operation. Not sure if it’s used in other cases.

not sure what cut through is but in standard Fanuc G4 is a dwell and s* is seconds of dwell. I’m trying to stop some laser burn jiggle at the beginning of each burn after a rapid move. In other words it starts to burn as it thinks its in position but hasn’t stopped vibrating from rapid move. Module hangs out a tad not reinforced enough.

In that case what I described may work for you.

Try the following:

  1. Set Cut mode to Line
  2. Open Cut Settings and go to Advanced tab
  3. Enable “Cut through” for Start pause time
  4. Change pause time appropriately
  5. Change Power to 0% assuming you don’t want to actually burn

This is only an option for Line operations so won’t help you for a fill.

What machine is this for? Have you adjusted wheel tension to minimize movement of the laser module?

yeah all is adjusted right, with new parts, trying to eliminated some line jiggle caused by laser coming on before it stops vibrating right after rapid move. All on cut lines so that should work., I’m using array for multiple same parts and have noticed as my parts get more involved that right after a rapid move more so on Y that I’m getting a little vibration after it stops moving. I think cut through will work fine.

Its a S9 with a S10 module on it. Gantry isn’t strong enough

Does this model use linear rails for the gantry?

I’ve not heard of others having the same issue but perhaps you’re pushing the extremes of speed.

your probably right on second count I actually was gonna go into firmware and slow it back down for rapid moves.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.