DXF file from Autocad Imports with wrong size


I’m importing DXF files to latest version of Lightburn (9.19) and the size of the drawing is incorrect. I’ve read all the topics I could find about the same issue to no avail. It seems that in most cases the problem is fixed by changing units. I’ve tried fixing the problem by experimenting to change to every unit in the “DXF Import Settings” but it never worked.

I use mm in Autocad and mm in the import settings of Lightburn.

The scale difference is an exotic 379% variance. The drawing is smaller on Lightburn than in Autocad.

Thanks for the help!

What version of AutoCAD DXF are you creating? I use ASCII r13.DXF and it works fine.

I’m using the 2018. I’ve tried in 13 and I have the exact same problem.

Does your DXF setup screen look like “A” or “B”


I’ve tried both. This is my settings panel. It seems the “DXF import settings” are now stored under “File Settings” instead of “Display & Units”.

![Lightburn Settings|595x500](upload://cm![Lightburn Settings|595x500]

My screen capture only grabbed the screen containing Display & Units. Are you sure the scale difference is 379%. Is it possible that it is 393.701% - just a shot in the dark.

Yes, you’re right! So you do have an idea about what’s going on?

I can’t recreate what is happening to you, but:

Scale factor from mm to inches is = 1 / 25.4 = 0.0393700787

1 inch = 25.4mm

1mm = 0.0393700787"

Move decimal place over twice, and you get 3.93700787 or 393.700787%

rounded to 3 decimal points = 393.701%

1 Like

Ok, understood. But why are there inches somewhere in the process? Is it an autocad issue or lightburn’s?

I would have to look at your DXF file to know for sure. Post it if you want to.

DXF often do not store the unit of measurement they were created in. If you model a file in inches, but import it as mm, it will be 25.4x too small. If you import it as cm, it would be 2.54 times too small, and so on. If the file doesn’t specify it, then you have to manually set the units to interpret the file in, before you import.

1 Like

Now I feel embarrassed : where do I post it? This dialog box doesn’t let upload DXF files.

This is what is happening when trying to upload the DXF file.

If you have a Dropbox or Google drive, attach a link to it.

You can just email it to support@lightburnsoftware.com, and include a link to this thread so we know what it’s about.

I have the same problem, but from Fusion360 and also from Vectric VCarve Desktop. When I export from Vacarve to DXF or SVG and import it to Lightburn it is a facto 1000 which it is bigger. I have stopped exporting to DXF and SVG and use AI instead, that works. It started with the last update of Lightburn.

The last update of LightBurn didn’t change anything at all with DXF imports. Which version did you have before?

Sorry for the late reply, had a holiday here. For some reason it’s working fine now and I didn’t change any settings. I don’t get it so I’ll keep working until I find where the problem is.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.