DXF import shows shapes dotted

I created airfoils in FUSION360. Saved as DXF and imported to LB. Results are:

Of course I need the lines to be solid. I tried AUTO-JOIN but doesn’t appear to do anything. My assumption is that all the dashes would be joined when using ALT-J.

So how do I make the lines solid so it cuts properly.

Selected lines are always dotted while selected - click somewhere outside of the selection box.
If, for some reason, they are actually dotted when not selected, can you please upload the file here?

‘Join’ takes multiple disconnected shapes that are touching, but not actually a single path, and joins those paths. The important bit there is that they are already touching, so it’s obvious what has to be connected together.

Huh. What is obvious. The lines were solid in the DXF.

Have you un-selected it? If I draw a shape in LightBurn, it’s dotted and animated as long as it is selected:


That’s what your image looks like, so can you verify that it’s still dotted after you deselect? If it is, please email the dxf file to developer at lightburnsoftware dot com and I’ll have a look at it.

1 Like

I get the difference between selected and none. Will email DXF

@CXXXV, please offer detailed responses. Your response is not clear.

Do you see the marquee /animated, dashed line when this shape is selected?

Does this marquee change, showing the solid lines you expect when this shape is not selected?

If the shape shows as you designed in the external application when not selected, there is no need to email this file as that is working as expected.

The issue has to do with the auto-close tolerance. Setting this value low then imports correctly. Apply ALT-J and it’s all good.

The shape was in fact dashed. Thanks to Oz for providing the answer.

1 Like

Thank you for offering this update. Glad you got this sorted.

@CXXXV - Now I’m just really curious why your exported DXF files have the lines has dashed in the first place? Just tested to confirm and not even construction lines (which appear as dashed in Fusion 360) export as dashed. I feel like this is something that could be solved (so that you don’t have to join the lines when importing) by tweaking your Fusion 360 process. Do you mind sharing the fusion 360 file or at least a screenshot of your project?

Auto-join was set too coarse, and it was joining the wrong things. I’ll have to revisit that code and see if it does a “find anything within X” or “find nearest within X” as the join behavior.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.