DXF size importing incorrectly

I am new to laser cutting and the Lightburn software. Perhaps I am miss understanding something or I do not have things setup properly.
I am using one of JTech Lasers along withan ACRO frame. I DO NOT have everything wired in yet so the laser is not functional.
However I thought if I would import a DXF file into Lightburn I would see it displayed properly according to its size. I do have the print area setup in Lightburn to match the print area of my ACRO frame and it is set to Inches.
When I import the file it does appear on my display but off the build area and it is very small. I can move it to the print area where it is still small and no where near the actual size.
When I import the DXF file into another program it shows the correct size.

What am I do wrong?

Thank you - Alan

DXF files don’t always have a unit of measure stored with them. Look in the LightBurn settings in the File section for the DXF import settings where you can specify the units. If the DXF was saved as inches, but you loaded it as mm, it would be about 1/25th of its size.

Thank you for your assistance. Got that corrected now.
However when I imported the file it displayed way down in the corner off the cut area. I had to select it and drag it onto the cut area and position it to the origin.
I am use to other programs that will place the file directly on the area.

Do I again have something setup wrong or am not aware of?


LightBurn imports files into the center of the current view, wherever that happens to be. You can select the shapes and hit ‘P’ to center them in the page. You can also just drag from Windows Explorer directly into the workspace where you’d like the file to go.

Always something simple!
Question on registration: Got LightBurn thru JTech a while back. Download recent update before my one year expired. Now every time I bring LB up it comes up with the popup telling me how much time I have left? Little confused as I thought I could use it forever and just not receive updates. I plan to keep it updated regardless. Will the popup continue ?

Screenshot the page? It’s only supposed to tell you your license is expired once. In trial mode it’s every day. You might be in trial mode.

Interesting - I went into settings like you suggested to get my display corrected. I powered down my PC and then powered up . Started LB and no Popup.

I’m good until I discover something else I do not understand!

Thank you - Alan

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.