Elekscam laser etcher

I have a elekscam laser etcher from a few years ago. I can get it to work on Benbox, but can’t seem to find the right settings for lightburn. It runs on Benbox with an Uno selected. Any ideas? Thanks!

Did you go though the setup for LightBurn software?

It’s also a tip for us if you let us know what you are trying to do that you “can’t find the right settings.”
Can you connect? Can you fire the laser? You need to give us something to go on besides it works on Benbox but not Lightburn.

I looked your machine up, does it know how to home on power up?

LightBurn supports a great number of devices and as such requires you configure it for your device.

When I go to print after starting everything up, the laser goes to full intensity and the X.Y axis just moves on one of the axis (I don’t know which is which) but just burns a straight line when attempting to etch a circle.I have tried all three of the GRBL set ups, and even tried CanCam and a few others, I don’t see it homing on power up. Also when trying a second etch (same circle) it looks like it does move in a circle, but its really small (1/8" or so) and I have drawn a 1" circle, same when I made the circle larger.

Did you go though the setup for LightBurn software?

I don’t have a ‘print’ button, what are you doing exactly?

I am confused here.

When you power it up what happens? Before you do anything, what is it’s behavior?

When you configured LIghtburn for your machine is it metric or English? You speak in English but if it thinks metric…why we lost the Mars Climate Orbiter at $125 million… Some solid state diodes deal in inches. So check, both software on your pc and the controller.

Are you just re-running it?

If you can do this with BenBox can you save the grbl file? The two programs should generate very similar code. Can you post the actual .lbrn2 file?

Sorry, I should use the proper terminology when asking questions. By “print” I meant press the PLAY button to start etching. My computer for etching is upstairs and does not have capability to go on to the internet, so by the time I get down here to type responses, I kind of get lost in what exactly I was doing. So… when I first turn power on to the computer and etcher and set up lightburn to GBRL or whatever “setting?” the laser turns on and burns for a few seconds, I manually push the button to turn the laser in to low power so I don’t burn a hole through my workbench. At this time, I’ll draw a circle in LightBurn set to metric or inches and try to etch and in inches a 1" circle 1: won’t etch with laser turned back on, 2: is very tiny, not 1: but maybe a 1/16", I can’t really tell because it doesn’t etch, and it seems to only go in a straight line and turn on the laser but not make a circle, like X is working but Y turns on the laser. Then I swap GBRL setting to GBRL-1 or something, and I get it to make a circle, very tiny, but no laser at all.

When I configured LightBurn it was initially in metric, I have swapped it to English since, seems to have no effect. I remember the Mars Climate Orbiter! A few bad calculations in English instead of Metric and the whole thing is thrown off.

I don’t know if I have Metric or English diodes. Or how to check that.

I am just re-running it.

I don’t believe I can save anything in BenBox. Which sucks because I have to re-create my circles every time. I’m actually trying to make a circle in a circle (donut) for a work project.

Also, BenBox was a pain also. Had to find proper settings to get the laser and X & Y to properly operate. It’s not like it says this is for X and that is for Y, I had to experiment with numbers in ??? input boxes until it just started working. In LightBurn I can not find settings like in BenBox. It’s all new to me. Even the etcher I’ve had for years, there’s no name on it, so I assume its the Elekscam E3. I did buy it from Amazon 2-3 or more years ago.

I saw a video on your machine, it advised going to low power or ‘weak laser’ before turning it on. They do not give a reason, but probably for safety issues. NO machine would enable and the fire the laser on power up.

Sounds like you’re running the laser via sneakernet from your pc? Is that a USB stick?
Running the laser program from the panel of your laser?

This makes little sense to to me. Do you mean you set the laser device to grbl in lightburn? I thought you could not connect the lightburn running machine to your laser?

These devices operation are critical that they are set up properly. How do you know if you’re getting the right results if you program in inches and engrave in mm? It’s going to be 1/25 of the size. I keep after you for “setting?", your reply of ‘whatever “settings”’ frankly, is frustrating. 99% of these issues are settings. Now that that’s off my chest…

Lets try this tact. First with nothing connected to your laser but the USB connector and the laser power supply. Set the laser switch to ‘weak mode’ I think is what they called it. Low power anyway. You don’t want to be connected as to any programs, just want to give the board 5v from the USB cord.

Power up the laser on the control board switch. Does the laser fire?

If so you have a hardware issue.

If it does not fire, then…

Please clarify how you moving the code generated in lightburn to your device. What gcode sender are you using?

Take care, we’ll figure it out… Hang in there… :slight_smile:

Low power apparently is just a button on the laser that won’t allow it to go to full power. I think for safety but also to see where it is on the etching surface?

I set the LightBurn program to GBRL in the “laser” panel in LightBurn. *t has a window that says Laser - LightBurn 0.9.24, then Pause button, Stop button, Start… At the bottom is three boxes , Devices, drop down box Com3, and drop down box which is currently set to GRBL -LPC. I am directly connected to my computer via com 3 USB. I’m not worried about size right now, I’m more worried my etcher thinks the laser is actually the X or Y axis, which would explain why it fires the laser and only goes in a straight line.

OK, in “weak” mode, I think, cause the button is up or down, I don’t know which way is “weak” but in the down position it is a weak laser shows up on the etching surface. You know, I think it is used to focus the laser… Anyways, if I push it again so the button goes up, the laser turns off. When connected to LightBurn, com3, with GRBL-LPC selected, weak laser off, a circle inside a circle (donut) drawn to etch and press start, the ethcher appears to draw a straight line then go back on that same line, then move in a circle and go back to the home position never going out of weak mode. Same thing but with laser not in weak mode, same movements and the laser is completely off. Also, the LightBurn program seems to still be running! 99%… I have to press “Stop” to be able to run it again.

I’m not sure what G code sender I may be using, I thought LightBurn did it all.

Does LightBurn Laser window on the bottom right have “Ready” in the top left? That says it’s connected.

Can you move the head from Lightburn? I’m trying to figure out if you are actually communicating what you think to the grbl processor.

Some grbl boards allow a pause, but some you have to abort the run to really get control. At this point, lets just see what is working.

In the upper right, select the ‘Move’ tab and see if you have proper control.

Take care…

It does say ready. Move tab… Clicking on Left, or Right, or Up, or Down arrows, the darn thing jumps in one direction, then jumps right back where it started, no matter which button I press!

Move Z + or - will move in the same one direction, pressing again moves it right back where it started, only moves about an inch, but really fast!

I then changed the Laser - lightburn window from GBRL-lpc to GRBL-M3. The laser went to full power for a few seconds, and the jogging is the same.

If the controller has benbox, you would need to flash this board with a supported firmware. LightBurn does not support benbox.

I thought the controller was just using BenBox just as LightBurn is. The controller is a UNO I think. I can run the laser with BenBox as long as the settings in BenBox are set correctly. Do you know how I would flash the controller fo LightBurn, if that’s what this is? BTW I really love all the help!

Google “install grbl on benbox” and you’ll get a list of videos and articles on how to change the firmware.

It appears to be a 328p, so finding a hex file of grbl should not be an issue. If you can save your setup it’s always a good idea. At least if it has $$ command output, copy it to a file…

If you have problems try google and some reading… There’s always someone around here if you get too stuck. Although this is really outside of Lightburn, I think.

Good luck, take care…

You can also use our Search, found at the upper-right of every page here, for “benbox” to get a bunch of previous posts on the subject. :slight_smile: