EleksLaser A3 w/ Limit Switches Not Working Correctly... Help?

I have a EleksLaser A3 Pro that I purchased last year. It worked great with the EleksCAM software, but it did not support homing or variable power output to make gradients. I just recently added the EleksExtra kit that includes limit switches. I followed the instructions here to the best of my ability putting the switches in the recommended location: https://wiki.eleksmaker.com/doku.php?id=extra_module

I enabled the homing feature in Grbl using $22=1

The first time I tried to home, it went in the opposite direction of the switches and hit its mechanical limits.

I entered $23=1. The homing feature seems to work perfectly now, gently bumping each switch twice and backing off. I set the working size to the actual usable area in Grbl as well as Lightburn (370x262mm)

I placed a small test/calibration image in the center of the work area. When clicking start, the X axis slams against the opposite end, and the Y axis moves about 2/3 of the way to the opposite end and it starts printing against the side of the frame.

I noticed after homing the laser and selecting “Get coordinates”, I see strange values (X: -429.00 Y: 219.00 Z: 0.00) This doesn’t make any sense to me.

I followed the guide here for common Grbl setups: https://lightburnsoftware.github.io/NewDocs/CommonGrblSetups.html

When typing G0 X0 Y0 to find the machine origin, it does the same thing as before, maxing out the X travel and moving 2/3 up the Y.

What am I doing wrong? I’d really like to purchase this software if I can make it work.

Here’s my current Grbl settings:


According to a chart I downloaded, the $23=1 just changes the direction of the homing cycle. Check your normal direction of x / y with move contols. They should move correctly depending on direction selected, if not the $3= command allows you to change axis direction without rewiring.
Setting Rev X Rev Y Rev Z
0 N N N
1 Y N N
2 N Y N
3 Y Y N
4 N N Y
5 Y N Y
6 N Y Y
7 Y Y Y

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.