Eleksmaker a3 dimension issues

Hello, i am having issues controlling my a3 with lightburn. Before it worked flawless, then i upgraded lightburn and been having issues. i re set up my machine. When it does square, circle or start functions it does almost a whole square around the frame instead of just the work i have. before it would do the frame functions no issues. almost like 100mm isnt 100mm?

When you say “I re set up my machine” - did you change anything in the controller, or just install the new version of the software? LightBurn tells the controller to move a certain distance. The settings in the controller turn that distance into motor steps, and that’s usually where it goes wrong… If the steps per mm setting in the controller is wrong, the output will be scaled.

Hi, I just downloaded the trial version of lightburn. I already see that it’s much better than EleksCam by leaps and bounds, and I will probably purchase a license after I’m done playing with the trial version and feel comfortable using it with my (for now) EleksMaker A3 Pro 2.5W engraver.

  1. My Mana controller seems to be an older version (purchased from Banggood in August of 2017), but, if I choose my device to be a GRBL-M3, the laser doesn’t respond to “home” command (no limit switches), and clicking start causes the motors to move several mm’s, but then it stops and the laser never fires… When I choose just GRBL as my device, it works. I thought I had read on this forum that if I have an older version Mana controller to set my device as a GRBL-M3.

  2. The coordinate system is all jumbled up, if I engrave or cut a text file (just one word), it comes out flipped over (in the X-axis). Are there settings in LightBurn to flip an axis motor or should that be done in hardware, by actually switching the wires of the motor around at the connector end?

  3. on day one (yesterday), if I have 3 separate-color sections of my file (ungrouped vector art), the order of engraving/cutting followed the order I set the colors on the top right area of LightBurn. Today, If for example I have the order as Black, Blue, and Red (top to bottom), it started cutting the red color lines 1st, then it went up the chain of order backwards. Did I by any chance toggle a switch (in the software) that caused that reversal?


  1. Without limit switches it’s not possible for your laser to home. Home means “find the limit switches”. You might be thinking of “go to 0,0” which isn’t the same. The movement you get is probably the laser looking for the switches, never finding them, then going into a fault state which requires resetting. https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#22---homing-cycle-boolean

  2. Setting the location of the machine origin affects this. GRBL should be front-left. If you chose front-right, that would mirror everything horizontally.

  3. Click the “Optimization settings” button and make sure “Order by Layer” is the first (probably only) thing in the upper box. Here’s more info on how the settings work: https://github.com/LightBurnSoftware/Documentation/blob/master/CutPlanner.md

Sorry, I wasn’t near the machine before.

I meant when I press “Go to Origin”, which was bringing the laser to the position it was when the machine was powered up. So when I choose GRBL as my device, it does that, but when I choose GRBL-M3 it doesn’t.

I have a lot to learn regarding how to set up the proper orientation of the machine so it is properly represented in LightBurn. Not sure if the bottom right corner of the machine is with the Mana SE board is near me and the diode laser is facing away from me, or what.

There should be no difference between GRBL-M3 and GRBL with the way the origin commands work - they send the same command. You might need to manually select the COM port again after changing devices.

The simple way to figure out where zero should be:

  • in the console, type G0 X0 Y0 (this tells the machine to go to the origin, or startup position in your case)
  • type G0 X20 Y20 - This moves 20 units in X and Y, in the positive direction

That second command should move the laser in the direction of the rear right of the machine. If it doesn’t, turn the machine around so it does.

Thanks, I will try this later on.

@LightBurn, I went back to the machine, and tried this:
I clicked on the “Move” tab, and when I mouse clicked on the up/down arrows, the gantry moved up/down (y-axis) properly, but when I mouse clicked on the Left/Right arrows, the Laser module (x-axis) moved in the wrong directions (left arrow moved the laser to the right and the right arrow moved the laser to the left).

I checked the connectors on both ends of the x-axis stepper motor, and they looked to be physically correctly plugged in. I don’t know if the motor is incorrectly wired to the connector or not.

My question is: If my project comes out flipped side to side over the x-axis (mirrored horizontally), is there a way in LightBurn that will let me mirror it back horizontally.

Right now, if I want something to engrave properly, I have to mirror it horizontally manually before I send it to the laser machine (EleksMaker A3 Pro, with Mana SE Controller).


See my original point #2 above: “Setting the location of the machine origin affects this.”

This is where your origin should be set for GRBL:

You can mirror horizontally by choosing the right corner instead of the left.

Thanks, @LightBurn
It worked. That flipped the x-axis!