Eleksmaker A3 Pro, dead axis, no laser fire? Help?

Upgraded to Windows 11 and LB 1.3.01 and uploaded GRBL 1.1f to Eleksmana v5.2 with a previously functioning Eleksmaker A3 Pro engraver using LB defaults. Now there is no power to the steppers, they won’t energize/enable. The laser is powered but it won’t fire. I’m connected and getting feedback from the console and I’ve tried three other software packages with the same results. I’ve also tried a different GRBL controller board with no luck Lost the previous config when the PC hard drive died. Is this the weirdest thing ever? I’m dead in the water and drifting.



































What was the source of this firmware?

What version were you running previously? Do you have access to the previous firmware that you could potentially reload?

Can you confirm that this was working immediately prior to W11 upgrade and GRBL 1.1f upgrade?

Can you elaborate what this means? In what way is it powered?

Did you disconnect anything during this whole upgrade process? Assuming no hardware issue for the moment it would seem to me there’s a problem with the firmware itself. It’s possible that the firmware loaded is not configured for your particular hardware. I would expect the steppers to work in most common scenarios however.


Meaning the laser fan and power light are on as one would expect when the controller is powered up. Commands to fire or test the laser have no effect but i can see them being sent and responses being received in the console. The same problem with stepper motion commands, i can see them being sent and responses being received in the console. I uploaded the 1.1f High Freq PWM version from T2 on the Eleksmana 5.2 board. The prior version was 1.1e which also did not work with new PC and latest LB to begin with. It was running LB on Windows !0 and it functioned perfectly before I shelved it.

Yes, long enough to swap in another similar but different brand of board also with GRBL 1.1f., effectively creating a “new machine” for a time. That didn’t work either.

One would think so yet they act as if they are not enabled.

Epic bafflement. It was working a year ago but changing PC’s with Windows 11 and now running the latest LB killed it. Like changing your tires and now the car won’t start. It makes no sense at all.

I’m about to do something stupid like buying another different engraver and chucking this one just to get on with this.

It’s unlikely that Windows 11 has anything to do with it. As long as you have serial communication that should be sufficient to allow the controller to do what it has to do.

LightBurn similarly is not likely the culprit as it’s only sending commands to the controller to execute. So unless somehow LightBurn is not sending the right commands, which is extremely unlikely, it’s almost certainly not the root cause.

Based on your current symptoms I think it’s most likely either a wiring issue or a firmware issue. I say wiring since the system worked before updating and since the other controller failed to drive the motors.

It may also be a firmware incompatibility issue since you’re dealing with an older controller.

I’d suggest first validating the function of the controller to isolate if the issue is in the controller or downstream of that.

Do you have a voltmeter and are you familiar with its function?

Solved… but… without an explanation. This one is gonna throw you!

In the Device Manager for my Windows install there are COM1,3,5 defined. Laserburn and other apps find my controller on USB-SERIAL CH340 (COM3) and will connect and communicate but will not activate steppers or laser. I switched to USB Serial Device (COM5) and WOW!!.. steppers move and laser fires.

Besides the different labels for the ports, the only difference I could find is 9600 bps speed setting for COM5 while COM3 is 115200 bps which actually doesn’t mean anything since the apps set the port speed. Go figure that, huh? Put a pin on this one for others. No one should go through what I’ve suffered for the last three days. “M’brain as esploded!” - Cheeseburger Cat

1 Like

I’m a little confused by this, to be honest. I’ve always thought that port speed was user configurable. At least on the devices I have.

Go to Device Manager in Windows, select COM port, go to Properties window. You’ll see settings for port config such as speed in bits per second, odd/even bits, etc. Those settings are relics from the days when COM ports were physical 9pin “D” sockets and you had to configure each variable to match your hardware.

Most people using computers now aren’t old enough to have ever seen one. They go back to the early 80’s. Generally, a “modem” was connected to them along with early mice. I’m a 68 year old geek. I was repairing those systems. I retired as an IT manager and a network engineer.

USB ports replaced them and the old COM ports are emulated on USB ports. In modern OS’s you can have as many “com ports” as you wish; 5, 10, 15, etc. That itself is obsolete but is retained for archaic interface protocols like that used for the large industrial CNC machines way back in the day and now desktop engraver/CNC machines.

Notice that you don’t need to set “port speed” when you plug in a mouse, keyboard, webcam, printer or any other kind of USB device. The designers of the hobbyist controllers retained the serial protocol because the designers of the Arduino did. So did those based on non-Arduino micro-controllers.

The software now sets the port speed based on a setting in apps like Lightburn, LaserGRBL and others.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.