Eleksmaker A3 pro settings to work


(Christian Piechowski) #1

Hey, I have an Eleksmaker A3 Pro and want to run it with light burn.
Lightburn recognized the laser. The problem is, the image is executed in the software but not on the laser. The slide can be controlled manually via lightburn.
Another problem is that the working area seems to be too large although it is correctly entered in the program. This means that the laser wants to go further than the range allows. Which settings do I have to make ? If everything works I would like to have the Lightburn full version.
Thanks for the answer


(Rick James) #2

We also need to know the firmware version you are using to run your laser. We have seen the Eleksmaker machine ship with an older version of grbl so if this is the case, go with the GRBL-M3 device in LightBurn. Ideally, you would upgrade to GRBL 1.1f and then use just the GRBL device.

Check your setting for $30 and $32 in the console by typing $$ and pressing enter.

$32 should be 1 (enable laser mode)

$30 should be 1000

The $30 value can be set either in your firmware to match LightBurn or in the LightBurn device settings (S Max) to match your GRBL setting.

The working area of your system is defined in both LightBurn and your firmware. Here are the latest docs for configuring the firmware. https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration

Here is another great resource for your setup.

http://wiki.eleksmaker.com/doku.php?id=elekslaser_a3_pro

As another member previously posted, "Scroll down to the bottom "operating instructions" And follow that, once you have it working in elekscam. It should work in lightburn. Follow the instructions to the letter and that will get you up and running…"

There is a separate group for these types of machines on Facebook and quite a few people there use LightBurn, so they would be able to advise you more. Facebook Support Group for Eleksmaker - https://www.facebook.com/groups/107222596696733/


(system) closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.