EleksMaker A3 Pro settings


(Juan A Sierra) #1

I just purchased a EleksMaker A3Pro and this is my LightBurn console reading, everything seem to be working ok, but I get no position reading, and seem that I’m not getting the full output re-out from grbl, $10-3, no $30, $31, $3If your laser does not turn off between cuts,
switch to the GRBL-M3 device
Homing
ok
error: Setting disabled
$$
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=1 (dir port invert mask:00000001)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=80.000 (x, step/mm)
$101=80.000 (y, step/mm)
$102=80.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=5000.000 (z max rate, mm/min)
$120=200.000 (x accel, mm/sec^2)
$121=200.000 (y accel, mm/sec^2)
$122=200.000 (z accel, mm/sec^2)
$130=5000.000 (x max travel, mm)
$131=5000.000 (y max travel, mm)
$132=5000.000 (z max travel, mm)
ok2.


(Oz) #2

The missing output from $30 is because you’re using an older version of GRBL, before those settings were added. 1.1f is the most recent, and yours looks to be 0.9.

When you say “I get no position reading”, that could be from the $10 setting (it should be 0). If you don’t have limit switches, you would need to manually position the head at the origin before powering up, or use the G92 X0 Y0 command in the console to reset the origin after jogging the controller to the front-left.


(Juan A Sierra) #3

What would you recommend, upgrade to 1.1 which I don’t know how, would have to do some research. Right now I have it setup to user origin and center and worked just fine this morning.
I used the low light to position my work without any problems.

The only problem that I have is a light burn trace when the laser move to the next area.

Thanks


(Oz) #4

If it’s burning when moving to the next cut, and you’re using the GRBL-M3 device, check that the S-Value Max setting in the Device Settings is 255. (the default is 1000 for new GRBL, 255 for older GRBL).


(Juan A Sierra) #5

Thanks, is set at 1000, will change in the morning.