Eleksmaker setting problems

Hi all.

I’m trying to customize LB for my Eleksmaker A3 (400 mm x 300 mm). I’ve read guides on how to set the origin, how to match User Origin with Absolute Coords and so on. But when I start, for example, a print for a simple circle in the middle of the board, the laser head goes up to the limits, hitting against the structure.

May I please receive a link to a guide/walkthrough on how to correctly set these parameters ? I wouldn’t want to spend days over randomly changing them and hoping for results.

Thanks in advance.

You put the laser head in the center, and set that to origin, and then used “User Origin” in LB and then it still went to the edge?

Here is a great resource for your setup.


As another member previously posted, “Scroll down to the bottom “operating instructions” and follow that. Once you have it working in elekscam, it should work in lightburn. Follow the instructions to the letter and that will get you up and running…”

If you don’t have limit or homing switches, move the laser head manually to front/left before powering up. It will use the power-on location as the origin.


I install Lightburn software to my pc. I used but i not satisfied with Laser result (making shadow lines) I uninstall software. When i realized it is not software problem try to install lightburn again and software is did not find my machine. I used create manually mode and try to start my laser. Laser shows his working (97 %) and when i try to controll laser head movement Message come up : Lightburn not responding.
What can i do Now?
Thank You!

Hi Rick, I’ve followed your hints, and it’s all OK !
To be sure, I’ve measured (moving with steps by 10 both X axis and Y axis) the workboard, and I’ve cut (lined) with Lightburn a rectangle 5 mm thinner , so I know the boundaries … Thanks a lot !

1 Like

You could tell us a bit more about your setup than the “ETE ETMATE” listed in your forum profile. I have no idea what that is or what drives it (controller/firmware). So let’s start with more data. :slight_smile:

My laser engraver is made by Bachin. Name is ETE ETmate. Basic Softwer is GRBL 1.1f.
Arduinno Nano panel
Thank you for your time/answer.
Kind regards

When you created the device, you may have left “home on startup” enabled. That would make it try to find the homing / limit switches, but if you don’t have them, it could cause an alarm state in the machine.

You also likely need to select the COM port your laser is connected to, at least the first time you use it. If you do not choose a port, the software will not show as connected.

Click here, where it says (Choose):

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.