Enabled homing cycle with GRBL - but laser doesnt stop moving

Hi - I used the grbl code suggested to enable homing.
now when I turn on the machine, the laser moves to the lower left corner and bangs up against the side and won’t stop trying to move beyond the boundary. I can’t stop it unless I unplug it from the port, then when I plug it back in it continues until an error message - Alarm 6 Homing fail. Reset during active homing cycle. I am a beginner and am lost

this is the code i see once it does stop
ALARM:6

Homing fail. Reset during active homing cycle.

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

error:9

G-code locked out during alarm or jog state.

[MSG:Caution: Unlocked]

ok

Homing

[VER:1.1h.20190830:]

[OPT:VZ,15,128]

Target buffer size found

ok

ALARM:9

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok

Can you confirm that in fact your machine has homing switches? If so, can you actuate them manually to trigger a stop during the homing cycle?

If you do not have homing switches then you should disable homing.

ok how do I disable the homing

This would be the reverse of what you did to enable it.

Set $22 to 0.

It probably didn’t come equipped to home, it’s an added selling point and more expensive.

If it was setup to home with switches, you wouldn’t have to change anything and it would have just homed on power up…

To confirm the machine is able to home, you should find a switch on one end of both axes. I doubt you have them.

@berainlb answered this one…

You have three ways to power it up…

  1. just turn it on let it bang until it thinks it’s gone too far
  2. move the head to the complete opposite corner, this will reduce the bang time
  3. unplug both motors, it will just think it’s moving the stepper motors… ensure you plug them in the right way… they are keyed, but you can force these.

At this point you should be able to talk to it with Lightburn… and make the needed changes.

Although this pounding sounds terrible, it really doesn’t hurt it… There is limited power most of the noise is the fields moving faster than the hardware can react. Don’t make a habit of it, but all of mine have been through a few poundings… :face_with_spiral_eyes:

I suggest you go to Edit → Machine settings and do it through the gui… the stuff is in [your language] there and not in numbereze. You can also save the machines configuration in case you botch something… Always a good idea to keep a factory setup around.

Good luck

:smile_cat:

Thank you!

I also went into settings and found an option to turn off homing on start up so I’m hoping that might work as well

Note that these are related but independent things. The setting you enabled is for whether or not you want LightBurn to request a homing operation at connection time. The setting for $22 is whether or not the machine is equipped to home. Many lasers will automatically attempt to home on power-on with that enabled.

Thank you for all your help!

Did you get it going?

How did you do it?

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.