Ender 3 laser don't start

Hi all!
I have just built a laser module on my Ender 3 printer by using the fan port.
Now everything seems to work, manual put on and off the laser by command M106 works perfect.
But when executing a generated G-code, the laser will not get switched on.

I think the problem is that the wrong command is given by the Lightburn software but I can not find the setting…

Also the homing button does not work, it will give a message Unknown command $H.

Setup is:
Laser : GRBL-M3 (1.1e or earlyer)

Hope you can help me out!

Does your Ender 3 in fact run a GRBL based controller? Or is this the default Marlin firmware that’s from the factory?

If Marlin, then I’d suggest changing your device type to Marlin.

I am not sure, I tried several and it just gets connected when i punt it on GRBL…
When I put it on Marlin, it keeps trying to connect, but fail…

When I go to printer info in my printer it will say:
Marlin 1.1.9
2018-08-01

Board:
Baud: 115200
Protocol: 1.0
PSU: Generic

That’s definitely a Marlin board then.

Try various baud rates and toggling “Enable DTR signal” to see if you can get it to connect. Make sure you’re on the right Port in Laser window.

Thanks a lot! The baudrate was the problem! In Marlin it will set automaticaly on 250000, but in Ender 3 you need 115200.

Now another question, do you know where to set the offset? My laser is attached to the side of the extruder so I need to make a offset in X and Y axis.

1 Like

In Edit->Device Settings there’s an option for “Pointer offset”. Configure there.

Thank you, everything works perfect right now!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.