Ender 3 S1 Pro Tips, Tricks and Suggestions

Thought I would start a new topic and try to gather all tips and tricks and setup help for Ender 3 S1 pro into one area. I will add anything I figure out as i go but if you have anything to add, please do since this is not working correctly yet. I must still edit Gcode manually for it to work.

USB Connection issues
Lightburn will see the Ender 3 S1 pro. If your having issues like I was you can try to uninstall and reinstall the device and or drivers using this link.

further info on this can be found here.

If that does not work be sure to try different USB cables and or USB ports.
After reinstalling drivers and switching cables and USB ports several times lightburn finally found my Laser.

It sees it as a GRBL-M3(1.1e or earlier)
However, there are several issues with the gcode it creates for the ender 3 s1 pro.
One is the first M3 needs to be a M3 I (that is a capital i)
This fixes issues with it controlling laser on/off

Also framing on machine will not work since the gcode header info it not in the right format. It should match this format.

;Header Start
;estimated_time(s): 11122.554
;MAXX: 149.48
;MAXY: 93.57
;MINX: 64.84
;MINY: 6.47
;Header End

G92 X0 Y0 Z0
G0 F3000
G1 F1500
M3 I

You could also add this to have machine BEEP when engraving is complete.
;beep when done
M300 S440 P200

And if you want to get use of more space on your bed, this will turn off the soft limits.
M211S0 ;Removes 220x220 Soft Endstops

M211S1 ;turns soft limits on again.

I am currently using the following settings in lightburn.
Light Burn Settings
Speed 25
Power 80
Marlin/GRBL-M3 (1.1e or earlier)
s-value max 255
baud Rate 115,200

If anyone has information on variable names I could use to create my own header that would be great.
Variable names needed.
we could have it auto populate with the correct numbers for framing would work on the machine when posting gcode to a flash drive.

Again, if you can help me figure out how to get the ender 3 s1 pro working better with lightburn please add your thoughts.

You could try a Custom GCode device with Snapmaker flavor and edit accordingly with Notepad++.

Making some progress now.

I have been trying to find how to access this custom gcode screen forever and finally figured it out. Click DEVICES, and CREATE MANUALLY, select CUSTOM GCODE, on the last setup screen you can select the Gcode Flavor. I am currently using GRBL-M3 but may try Snapmaker as suggested since it does almost output the bounds properly. not to hard to edit them to what is needed. Once this is setup you can now click on DEVICE SETTINGS and you will see a new tab called CUSOM GCODE. in here you can edit the commands sent to the printer for things like lazer on/off or the format for a cut line etc. I added “M3 I” to the TOOL ON command as well as FIRE ON and other laser related commands. I can now save gcode and run it without editing anything. YESSSS!!! Now to work on trying to get it to post the BOUNDS MAXX MAXY MINX MINY properly. I will keep you posted. Thanks for the help so far. Much appreciated. Here is what the screen looks like that lets you change the code lightburn sends to your printer. its almost like editing a post processor, best options we have so far.

Hmmm, M300 S440 P200 does not seem to work for me. Anyone get this to work?

Sorry not posting the steps.

What doesn´t work? Lightburn didn´t output the command? Your machine does nothing when it receives the command?..

?? I posted the steps to find this screen, keep reading.

code is sent, machine does not beep.

1 Like

NVM, i get what you meant now. Your sorry that you didn’t post the steps. lol. Ya i didn’t understand your suggestion at first but after another conversation with LightBurn support it finally clicked.

1 Like