Endless busy on NEJE 3 Max

Im running a neje 3 Max extended bed

I am now running the latest update 1.4.00
I have just updated the firmware via the neje site on machine

Previously i have run hundreds of jobs possibly 1500 or more with few issues till just this last period where i have had jobs stop part way thru and seeming stepper issues where images are failing to line up in x or y directions. I have tried changing scan angles.

Most common is this issue of showing busy. It frequently happens after homing, after running a job of after using the laser position button and sending the laser to a point on the bed

The pictures show laser busy and the console read out

The problems started while using a MacBook Pro and while i was able to hobble along using my windows laptop it was and still is an issue

I have done multiple restarts of my computers and laser

Thanks in advance for any ideas

That could be communication issues - we have a troubleshooting guide on that and since you are using a laptop take note especially of the ‘USB port sleeping’ part:

Connection Issues - LightBurn Software Documentation

In Edit > Device Settings your baud rate and transfer mode should be set like this?:


Also, since the busy error seems to happen for you more when repositioning, when you check the console, you may need to scroll up a little and make sure the busy state is not caused by some other alarm such as “target exceeds machine travel”, “homing fail”, or a shock/tilt sensor alarm.

Can you share any pictures of this problem?

Do you have the 810mm x 1030mm machine? With belt tensioner fitted?


I’ve been out of town. Should be home in about 12 hours. (Tonight) will update then or in morning

Yes I have 810 x 1030 with tensioners

Also if you have insight as to why this problem may have started after hundreds of hours of no apparent issues that would be great to know also

Thanks again

Hi Nicholas,

I have a blinding migraine atm. Hoping some meds might kick in soon.

I’m not sure how to quote you from a mobile device but yes some pictures of the work that failed to line up

This one happed when scanning -90°

This one I can’t recall the scan angle but I think it was ° and starting the entire group from closest the bottom of the picture.

I checked device settings and things were as you said they should be

Then I sent laser to a point on the bed and returned to home. No issue

Next I loaded a file and at some point I’m showing busy

This is the file

And this is the entire log for the session

I have also tried setting up a virtual Bluetooth port to step away from any physical connection but have had no joy doing this

Update then a fail … next reply

I have managed a virtual connection thru Bluetooth.

One coaster has just been completed taking about 8 minutes. No apparent issues. Little over burnt but that is a settings thing in cuts and layers.

Now moving on to a second one with adjusted settings and this is running fine so far.


It would appear to be a physical connection issue.

  • Either my USB extension cable (which is brand new and only 1.8 M or 6 ft long) or

  • the original data cable running from the machine thru the cable management tray.

**Any other thoughts and or observations greatly appreciated **

Was all excited , thought it was running via Bluetooth.

I got 5 coasters done then a break and came back to it. It stopped mid job a few times so shut it all down and started again.

Still stopping mid job as seen by the console pic

This is what I was trying to do. On cork

Even thought the job had stopped the laser window was reading’ready’ until I homed the machine then this

So then tried to exit lightburn and this

I decided to check if the virtual USB port was still connected via Bluetooth. All looks well

So now I’m back to scratching my head.

It appeared as if things were running slower than normal. Not sure what to put that down to?

After a restart here are all my $ settings

I would be very greatful for any thoughts or advice.

Once again

Thanks In Advance

Hi Dave,

That’s super interesting, what hardware did you use for that? If that is helping then it does point at a possible disruption to the connection caused by electrical noise/static buildup, as described in the connection troubleshooting docs.

I like that steam punk/Nautilus style art, but that’s a very ambitious job going on there with so many tiles! It is a risky business to stack the chips so high, due to the potential of the laser to lose position and then continue to be out with the rest of the job.

The image output seems to be slightly horizontally skewed so the first thing to check is is to make sure the machine frame is nice and square and not also skewed to the right at the back.

Rapid movement for engraving is designed to be done primarily with the x-axis on these machines - just rotate the image if you need the ‘grain’ of the laser burn to change. It doesn’t look like the big job was done at 90degs though? I would say the safest approach for this job would be to use ‘fill shapes individually’, (cut settings) with no more than 12 tiles in one batch. I would probably mark out where individual tiles should sit with some margin between.

It is possibly to make the job a bit safer to run by slowing down your engraving speeds, what were your cut settings for these jobs?

Your acceleration settings ($120/$121) look very conservative $120 could probably double to 500. You could reduce Max speed $110 and $111 (or at least $111 y-axis) to 10,000 as sometimes skipped steps happen for the fast G0 moves.

The console errors in your last post could be due to noise in the signal line, turn on ‘show all’ in the console window and you may see some weird characters which would confirm that.

Hi Nicholas,

Really appreciate your in-depth responses I’ll answer the Bluetooth in this reply.

Bluetooth connection

Firstly I start with the NEJE app. Must be this version or later. (I don’t believe you can run this on Mac so to update firmware you need to connect to a windows computer from time to time) I was using exclusively Mac once the machine was up and running.

Then upon opening the app and with my laser turned on I get this display below. Currently the usb cable is not plugged in so there is option available for a physical connection via USB

After selecting Bluetooth option I get my user interface

Down the bottom corner is the option to connect via Bluetooth to lightburn

That is when the connection bridge opens to connect via a virtual port thru the NEJE app

In this box is a link to ‘learn how’. This will take you to the web

On the web page it gives you a run thru various details and a link to download a driver that allows the Bluetooth connection

When installed and opened this is what the driver looks like. I have already configured it.

Yesterday I had about 5 connection options in the list. Just now I have deleted all but one just incase there was some kind of Bluetooth interference that caused my failure yesterday after I thought it was going fine.

I have also got a new printer/data cable to run directly from the machine to my laptop uninterrupted. This will be trialled later.

Moving onto the bed and machine set up. My background is carpenter / joiner. My nickname used to be mm man do to my fastidious nature. Yes the machine is within 1/2 mm of square over the entire area

I have done large runs like the ones you saw in the previous post on numerous occasions with no incident. I do take your point. The bigger or more you do at once the more room for error. As you could see the first row started at centre of coasters but gradually slipped to the right. It was as though it was adding a step or two with each subsequent row on the x axis. This was why I switched to the Y a sis with -90° travel. It appeared to somewhat alleviate the issue but there were still problems. About here was when it started to just stop mid project or show constant busy

Well I tried the blue tooth again and rotating back to to 0°

All was going well then I heard it stop

And the log shows nothing

The only thing I did notice was a notification for a message on messenger. Could it be in this instance the messenger notification via wifi created an issue.

I’m going to try again with wifi turned off

And turned it off and still no good. Stopped and no errors showing


I am away for work again and won’t get further time on the laser for at least another couple of days or so.

After the last post I was able to do a couple of coasters with no issue using a new printer cable. After this I did an enlarged version an a cork tile 300mm x 300mm or 1’ square. This went off without a hitch.

Next I’ll try a significant burn. Possible one of my 3 hour jobs and see how this goes.

Thankyou once again for your input.

I’ll be reviewing all your advice including speed recommendations etc

I’ve not spent any extensive time on my laser as yet but with the few jobs I’ve done it seems to be working ok again. End of the day it may have been a cable issue. As yet I have not returned to using my Mac.

Jobs do seem to be taking excessively longer than the preview suggests. Say 55% longer

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.