Endstop config not working on K40

Hello @all,

i changed the mobo from my K40 laser and installed the MKS DLC32.

Axis are moving and laser is working if i start a job. The only thing thats not working after the change are the endstops.

This are my settings:

Auf Verbindung warten…
[MSG:Using machine:MKS DLC32]
[MSG:Mode=STA:SSID=F 2GHZR:Status=Connected:IP=]

and this is how i connected my endstops. Tried with Signal and GND on NC (was the original connection) and also tried with SIGNAL and NO.

Also tried to change the Value $5. If its 0, the homing wont start and i get an error. If i change it tot 1, the homing cyclus starts, but nothing happens if i reach the endstops and motors are still running till i power the system off.

dont know whats the error. Even tried to change $20 to 22 with other values, but no luck.

Wrong connection?

What specific limit switches are you using? If unsure, can you take a clear photo of it?

For $23 to work, it requires that you have limit switches enabled… Setting any of these to 1 enables that operation.

$20 soft limits
$21 for Hard limits
$22 Homing cycle enable

You’ve effective covered up where/what you have blue and black wired, it appears to ground.

What kind of switch do you have? NO or NC?

Generally a NO switch is used, and it’s wired to ground. When active, the ‘signal’ input is pulled low (to ground).

A NC is opposite, as it breaks the connection when active.

I believe you have an incorrect schematic…


I have the og endstops connected in my k40. The original cables runs from C and NC. Like shown above.

But even with C and NO its not working

I can’t help you if you don’t answer my basic questions about the device.

Do you have a NO or NC switch?


I guess nc, cause that was the regular connection

No guessing … wiring is different depending on the switch type…

Without this, I am not sure how I can help…

  1. do you have a voltmeter?
  2. can you post a picture (or link) to the switch?


I had the endstops in my hands and saw the description on the pins, so thats all what i say. Cables were running to pin described as C and NC.

Ill check the connectivity with the voltmeter if im at home.

But like i said, i tried both pins.

You can’t use both no and nc switches together or simultaneously.

Even if you have it wired right there are other configuration options that might have an effect on how the switches are read.

You need to find out the technical part of it so we can ensure it’s wired right, before we look elsewhere.


I dont use them at athe same time. Like i said i tried it with both versions. None of them were working, thats why i was asking.

What configuration do you mean if its connected right?

Your drawing specifically shows both in use…

Your configuration says you have NC switches

Let me clarify what you are attempting to do…

The input to the controller for the limit can be configured (via $5 setting) to be either pulled low from a high state (NO type switch $5=0) or it can be pulled high from a low state (NC type switch $5=1).

If you follow the schematic on the side of the switch, it shows which is the NC/NO connections.

Most of these machines use the NO type for a pull down operation.

Wire the common (one side) of the switch to ground, the NO connection goes to the controllers input. You will have to change $5 to 0.

This is the most simple…

Can you try that?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.