Engraving issues post Ruida controller swap

Hi all,

I have recently swapped a Leetro controller for a Ruida 6445S this is in a Laserscript 6090 60W machine that was working fine prior to the swap. I have successfully managed to swap the controller and the machine is cutting and engraving, I have tried to mitigate the issues I am having by ensuring that the laser is aligned and the mirrors secure, Lens has been replaced, Head focused, the machine is stable and does not move during use, axis calibration has been done a few times now, scanning offset settings have been adjusted successfully, checking the rails are free and lubricated, getting the belts to the correct tension and finally checking all connections are tightened… Connected to the controller via. USB to a Lenovo laptop running windows 10.

However, I am having issues with my engravings skipping every so often, I have a small test file (40mm circle with Test text inside engraving at 400mm / 30%, cutting at 18mm / 39%) which never seems to shift. The shift occurs when I do any other engraving see pictures attached, it also varied with severity. I have gone through de-selecting the flood fill settings and selecting fill groups together in lightburn but it has not made any difference.

Any help will be much appreciated because I am a slight loss as to what is going on and need a fresh pair of eyes!


The second picture looks like it has lost steps… Do you have to re-home it when this occurs?

What kind of acceleration values are you using ?

Is the anomaly only on one axes?

It’s always nice to give us some kind of an idea on how the material is sitting in the machine… x and y directions…

:smile_cat:

Hi, currently the laser goes back to home/origin after every job and when power is turned on and it will when commanded.

It only occurs in the X axis the shift.

The engraving is set to 300mm/30%, see images below for settings




I was trying to clear up what happens when a problem, like the bottom photo occurs. Do you have to reset the machine or will it return to home ok? I’m trying to eliminate a lost step issue.

:smile_cat:

Hi Jack,

It returns home no problem I don’t have to reset.

One thing I have just noticed, whilst screen grabbing the settings. X acceleration was set to 10,000 (which I have changed to 3000)

Hope this helps, I will try with ammended settings to see if it has made a difference.

Generally speaking when you lose steps it will make an sound that can be minor or major depending on what you ask it to do…

I don’t see anything in the configuration that I would suspect.

If it returns to it’s origin after a failure, then we can eliminate the stepper being an issue.

I’d attempt to make duplicate the process and see if I could make it fail in some manner we can associate it to a cause.

Something like a rectangle or a ‘rectangle within a rectangle’ …

Thinking something like this…

Screenshot from 2022-09-01 15-55-29

From your explanation it sounds like a configuration issue… not sure where to point you… it looks ok.

:smile_cat:

Now that you mention the sound it did make a small clunk and the machine jumps slightly when it has failed on that portion of the engraving, almost like it overshot it’s mark and corrected itself, however it always goes back home. It has made that noise on several occasions during engraving the text. When that happens that’s when I get the scanning shift on X, other occasions it’s as if the laser is on when it shouldn’t be and I get scan lines outside of the engraving. Also not sure if this information helps it seemed to occur when I reduce the scan gap down to 0.02mm, when it’s set to 0.5mm the scan tests I have run for backlash are fine with no distortion and subsequent text engravings go well.

I will triple check my settings and then try the rectangle and see what outcome I get and hopefully replicate the fault, the two images are only a handful of failures trying to engrave, the burn pile is increasing :rofl:.

Thank you for your help, much appreciated.

Right, done a quick test like you said rectangle within a rectangle, single direction scan gap at 0.02mm 300mm/30%. No shift at all, see picture. Laser head returned to home.

Also tested if home was in the same place by sending the head home and firing the laser then moving it and sending it back home and firing it again, both spots were in the same place.

Ran two different texts at the same speed and power settings and the same thing happened but this time I noticed the scan reversed as if it was got to the end of one line and doubled back on the next line.

I expect some type of issue, so I’m not sure of what I can suggest… Might be worth sending it to support and see if they can give you a better idea…

If you could post the offending code that causes it to occur it might help…

Maybe @JohnJohn has some idea of where you should check next… If possible upload the .lbrn2 file…

:smile_cat:

The engraver seems to be well calibrated and well controlled. It doesn’t seem mechanical to me. I know that’s really ethereal but that’s my impression from the images.

I’d like to confirm that the file appears intact (undamaged) on the screen of the controller.

My next thoughts would be related to grounding and system noise inside the chassis while the engraver is running.

Hi John,

Thanks for the insight, interference could be an issue I will have a look at what wiring is close to each other.

Now that you mention it, there has been no previews available on the controller from files sent via USB. I am using the USB that came with the controller. Is this what you mean by intact?

Thanks for your assistance so far.

Can you set it up with Ethernet? That is much more dependable…

When you send it to the Ruida, and select the file, you should see the image…


If you can ‘drop’ the offending .lbrn2 file here it would be helpful.

You can ‘drag and drop’ it on the reply window, or use the upload icondownload-icon-background in the tool bar…

:smile_cat:

Hi Jack, Sorry I did mean to upload it here it is
Hollie Cupocake deboss.lbrn2 (34.4 KB)

I have been trying to set ethernet connection up with the controller however I have had no success hence using the USB. RDWorks does not recognize the controller but lightburn does. I will try again to set it up.

As for the preview of the item, I can only see the image when I select the file from the Udisk. If it is modified on screen the preview disappears, unsure if this is normal? Files sent by USB load into the controller however do not appear as a preview on screen during job run. Last night I loaded the file from USB to Udisk to run and the file was carried out perfectly with no skip, preview was shown on screen.

Will hook up ethernet and play around with it some more

I did not have the font you are using, but it looks ok to me…


What is modified? If you change something, such as speed or power while it’s loaded you lose the preview on the Ruida console…


You should see the ‘work’ on the machine console when you load the artwork. Sounds like some kind of usb issue…

Is only that single file and it works with a memory stick… ?


Give Ethernet a try… I switched to it within a couple of days trying to use the usb port…

:smile_cat:

Strange how it repeated the shift in X on each of the things.

Hardly any of my USB sent files are shown on the screen when they are sent if I’m honest.

There were several other files that failed leading up to this but this was the only on I stuck with to keep it consistent.

I’ll hook the Ethernet and see how I get on with the results.

Update: Connected via ethernet and have run the file again and it has come out ok, will run more jobs and see what happens!

Screen previews have started to appear but so far engravings seem to be ok!

Thanks for your assistance people the machine is running as expected, I would not have guess USB would have corrupted the files during transfer.

I have been making and it’s been without fault, I have a minor mismatch when cutting circles but that is alot less serious than the original issue.

Thanks again!

Great … glad it’s up again… mark it as solved, if that’s the case.

Take care

:smile_cat: