Engraving offset to line

Hey Guys,

We are having an issue when engraving that the engraving is slanted but the actual line outline of the lettering is perfect. It doesn’t happen all the time so not sure if this is a data issue. Have tried things like renewing the belts and making sure they are tight on the x and y axis, changed usb cables and even tried CAT 5 cables but does not make a difference. Could this be a controller issues?

I am at a loose end here so if anyone has experienced this or knows what this could be your help would be gratefully appreciated.

1 Like

What are your cut speed settings for both layers?

See this doc.

The engraving is set at 500mm/s and the outline is only 10mm/s, I would say engraving is fast but we have had this setup for at least 2-3 years and only now recently issues have started.

Thanks Parsec, I have checked the PWM and they are both turned off on each axis so I haven’t changed them because I have never had to use them before. I didn’t really want to change settings if it has been working fine for the last couple of years especially when we are doing 20-30 of these a day and then the odd occasion this happens

For reasons that I’ve never seen explained, the Ruida controller’s pulse edge gotcha depends on the exact layout being engraved.

It might be due to having exactly the right number of motor steps across the entire width of the engraved area or something equally uncontrollable that happens only once during every third blue moon.

In any event, what I’ve seen around here suggests flipping the X axis edge polarity will cure the failing layouts without affecting any of your existing layouts.

It’s easy enough to check and revert if I’m being wrong in public; definitely tell us what happens!

Thanks Ed, I have just tested that and my very next engraving worked fine, I think I just have to see how this works out long term now.

Well it didn’t last long and happened again, engineer has just come out and tested and looks even worse. Sometimes angled to the left then sometimes angled to the right, we even downloaded files to pen drive and did it direct from machine but still having issues. Engineer checked everything but hasn’t seen this either said potentially could be controller/power supply issue?

Another good theory shot down by evidence! :frowning_face:

At this point I’d grab my oscilloscope and look at the STEP pulse at the controller, because it looks like that signal isn’t doing what it should. It should be a nice clean low-active pulse, although it runs in current mode rather than voltage mode and you really can’t tell what’s going on inside the driver.

No matter what I saw, however, I’d be sorely tempted to order another stepper driver brick and swap it in, because there’s no easy way to diagnose a failing optoisolator.

While you have your head inside, make sure all the wires are snug in their terminal blocks and the ferrules are well-crimped on the conductors. We’ve seen loose terminals, uncrimped ferrules, and an assortment of barely working jank inside other lasers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.