Engraving problem on 1.1.03

I upgraded to 1.1.03 and since then when I activate flood fill it engraves letter by letter and greys out the options - fill all shapes at once, fill groups together and fill shapes individually. Is it me or the software that’s doing something wrong?

Mine is the same. I believe it’s expected behaviour.

The docs suggest that Flood-fill is for designs with large uncomplicated open areas like large rectangles. It may be not work well on intricate designs.


It’s like this since update. It wasn’t like that before.

I did also notice this change on a cross hatching I was doing often. Very glad to see this topic - anything with Flood FIll may have changed with this update.

Hope someone from Lightburn will answer soon.

Neither are doing anything wrong - it’s working exactly as intended.

Flood Fill used to allow you to fill all at once, or by group, or by individual shapes, but almost no one understood how those worked, and “fill all at once” was the default. With this setting, especially with moderately complex designs, flood fill would bounce all over the place, leaving lots of gaps, and generally making a huge mess.

By forcing it to consider only single shapes at a time, the end result is much cleaner, and less likely to have excessive travel moves and gaps in the output. This was an intentional choice by me.

1 Like

Ok I understand now. But when engraving text it needs to be off. And I see designs with text get quite slower than they used to. Never had any issues from jumping from here to there and you can see cleaner if you make VERY VERY detailed pic or something. I kinda liked the way it worked :slight_smile: Have to try it with some design that has gaps in it to see if its quicker than before. Because I think most of the times all of us want speed :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.