Engraving Speeds - How can I improve them?

I set out to laser engrave a cutting board (2 of them actually)

The engraving on the left was done in LightBurn and took a bit over 143 minutes. I used the following settings

Mode - Image
Speed 1500 mm /m
Power 100%
Line Interval .133 mm
DPI 191
Image Mode Threshold
1 pass

The board on the right was finished in LaserGRBL. It took a touch over 51 minutes. I used the following speed and power settings

-Speed 1500 mm/m
-Line Interval 7.25 lines / mm (if I understand correctly, this would make equate to each individual line being .138mm)
-Power 100%

There isn’t such a noticeable difference in finish quality to warrant the extra 92 minutes of run time.

How do I get LightBurn to run this in a reasonable amount of time?

It’s clearly not an issue in the GRBL settings and is a software thing.

I really do want this software to work efficiently since I am planning to add an actual laser cutter to my shop soon.

1 Like

There are a couple ways to improve this:

  • Enable “Fast Whitespace” in the device settings, so traversing the very large blank areas between cuts is done at a different rate than the cutting itself.
  • Enable the “Flood Fill” scan setting (intended for use on slower GCode systems, not DSPs)

I’m using JTech 3.8w laser on an with an X-controller from X-Carve.

Is there a general speed to set the fast whitespace scan too?

That would depend entirely on your machine, and how accurate it is. Having said that, you could set it obscenely high and the controller will limit it to whatever the maximum travel rates are set to, assuming those are properly tuned.

Okay. I’ll set it out at something like 4500 and see what happens. Where do I find the Flood Fill scan option? I’m not seeing it in the settings…

Double click the layer in the cut list. Flood Fill is in the lower right. Not recommended for general use, because it adds a lot of processing time, but for jobs that are mostly empty space surrounded by a border it can help a lot.

1 Like

This is what my editor looks like

Well this makes sense for why you are not seeing the ‘Flood Fill Scanning’. The settings you are showing are for an image scan, not a vector. Flood Fill Scanning is looking for empty space to speed the moves over if supported in your hardware.

Is there a reason this art is in the form of an image vrs a set of vectors?

If you can convert the image to vectors you’ll be able to use Flood-Fill, otherwise you’re stuck with the Fast Whitespace option.

Thanks. I’ll ask my wife is there is an option to save the file as a vector for Illustrator.