Error 10 writing settings back to device

I have just upgraded to the latest 0.9.13 build on an x64 windows 10 Pro machine and stumbled upon a little quirk. I have 2 saved machine configs that were saved from the previous version that loaded and saved back to the controller every time but now after the upgrade one now refuse to write back to the machine giving error 10.
After a little bit of hair removing I think I found out why. Maybe a possible feature as apple and microsoft would call it but in the non saving config I have soft limits and homing both enabled for my (K40 Laser clone).
If soft limits ($20) is enabled before homing ($22) is enabled it will fail to write and since the config file is saved in order it always fails.
If I manually enable homing ($22) then write the settings to the device only then can I the enable soft limits ($20). I don`t know if this is because I have a custom complied version of grbl 1.1 that I built from the current git-hub code or it is a feature that has slipped in thru the latest LB. I think maybe the latter option here because it worked perfectly without problems on the previous build.


Nothing has changed in the way that LightBurn emits the configuration to grbl but have seen that happen when manually setting grbl config before so I’d say option #3 - your version of grbl is fine and it’s always been a “problem” in LightBurn.

I just played with it and, at least for now, the solution would be to enable homing - let LB write the config. THEN enable soft limits and write again.

I’ll make a note in our tracking system to see if we can swap the emit order of $22 and $20.

Thanks for the fast reply Adam. I only noticed it while I tried to just swap configurations from the previously saved settings. I have a saved config for rotary device setup with no homing and soft limits and a seperate set for normal flat bed work with homing and soft limits enabled and that was the one that failed to write to the controller. I had just installed tmc2208 steppers and this just threw me off a bit.
thx again.

Ah, that makes sense. And yeah - that’s a bit annoying when used with the the ability to load saved settings. Should be an easy fix but might not make it in until the next non-bugfix release. Will discuss with the team on the timing of that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.