Error 22 after Line 4

I am getting a strange Error 22 message after line 4. Originally when I got it I checked on here as it was probably due to an ‘empty file’. I ran ‘Preview’ and sure enough there was nothing there. So, I ran it through Photoshop and changed the file size and pixel count, and when I put it back into Lightburn it was all there and engraved. Later when I tried it again, the same file, I got the Error 22 again??
Could anyone please advise why this may be happening. I am using the latest version of Lightburn

GRBL error 22 is “Feed rate has not yet been set or is undefined.”

Can you click the ‘Save GCode’ button, save your gcode as a txt file, then open it, and copy the first 10 lines into a reply here so we can see?

Hi, many thanks for the reply, the Total Gcode produced is:-
; LightBurn 0.9.16
; GRBL device profile, absolute coords
; Bounds: X-2147483648. Y-2147483648. to X-2147483648. Y-2147483648.
G00 G17 G40 G21 G54
G90
M4
M9
G1S0
M5
G90
; return to user-defined finish pos
G0 X0 Y0
M2

I am getting this every time I try to do an engraving now, even with one’s that have worked perfectly in the past

I think that I have solved the Error 22 message by ensuring that the image is smaller than the boundary box, and then centering in the boundary box. But in my resetting of everything I must have missed a setting regarding laser head speed. Previously I was engraving with a head speed of between 1000 and 1300mm/min, now I have have it set to approx 40mm/sec for the same end result. What have I missed?
Many thanks in advance

3000 mm/minute is the same as 50 mm/sec. You can change the settings to per-minute or per-second in the main settings page.

Your GCode shows nothing was sent, so your image or file was likely just over the page boundary and being discarded as a result.

This is also telling:

 ; Bounds: X-2147483648. Y-2147483648. to X-2147483648. Y-2147483648.

It means there was no content sent to the machine at all, so the bounds couldn’t be computed. I will check to make sure I have an appropriate warning if nothing gets sent at all.

Hi, many thenks for the reply…I had resolved the Error 22 issue by making sure the image was ‘in bounds’. There is a warning hat the cut may be ‘Out of Bounds, Continue anyway’, but no warning that it may not print. The mm/min issue was due to when I reinstalled and reset everything, the thing that I missed was that in Preferences I had it set as ‘Better for Co2’ and not ‘Better for Diode’, changing it to ‘Better for Diode’ resolved that issue also.

Preview will always show you what’s going to be sent to the laser - you should always preview first, as that will save you a lot of time and mistakes. Preview is the button that looks like a TV monitor on the main title bar, or Alt+P.

I ran preview as in my origianl post and saw nothing in the screen, I just didn’t know the ramifications