Error:22 Feed rate has not yet been set or is undefined. On or near line 4:

error:22

The feed rate has not yet been set or is undefined.

On or near line 4: Using Lightburn version 1.2.04. Working on a crib board. The crib board has three rows with holes, lines, and numbers. I’m using Lighburn to etch in the lines and numbers. I’m trying to do the numbers right now. I have successfully edged in the numbers using this same file for probably 30 boards. Today, I started my project by selecting the numbers in the three rows using the “fill” method. It successfully burned in the first two rows, then stopped and returned home. I then selected the numbers in the row that weren’t etched and set Lightburn up with the same settings as the previous numbers. Went to start the burn and the laser would not do anything. Just stayed parked. I then changed the “Fill” setting to line and it worked. I changed it back to fill and tried it. Would not move. Got the error message error:22

The feed rate has not yet been set or is undefined.

On or near line 4:" I have no idea why that error is there, or what it means! Hopefully, someone knows!

What I did in trouble shooting this problem, is, I rebuilt a new DXF file and started over with that. It worked for the numbers. Got them all etched. However I had two Script entry’s that I had to add. I built them both at the same time. Lightburn did its thing on the first one and proceeded to crash on the second. I got the same error message as before, with the laser not moving at all! I tied with the “Line” option and it worked, but wouldn’t work with the “Fill” option!

Pics of settings would help immensely


Here you go.

Nothing out of the ordinary. What machine qre you using? How is it connected to your computer? Changed anything else recently? Windows updates? Are you streaming via USB with original factory cable? How long have you had laser and used it successfully?

Its a 3018 pro. Using the laser that came with it. Connected via a standard USB cable. Like I mentioned this file has worked in the past. It’s got to be a software problem. Something wrong with my file/design. It’s like the program doesn’t see the word I have selected; therefore its assuming there is nothing to print.But, that is when I’m using the “Fill” option, if I use the “line” option, it works just fine.

Does it do this in the Preview window?

any chance you enabled Gcode cluster on Edit → device settings
By accident?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.