Error 22 & machine exceeds maximum range of motion

I recently purchased my Ikier 5 days ago while testing i needed to adjust the height of the laser module now it wont autofocus it goes to the top but does not complete the cycle and go down to the material, now when i reset the machine and try to start the setup procedure it does nothing and displays ‘‘machine exceeds maximum range of motion’’ I have tried the suggested settings in LB but when i try to set up the machine i constantly get this error, I never had a problem at all with my Ortur LM2 pro I’m considering sending the Ikier K1 pro 24W back and upgrading my Ortur.
Also getting error 22

Frustrated as cannot find a fix for this anywhere

Am I being Stupid DUH!


Hi Trevor,

Can you take a couple pictures for us
EDIT > Settings
Edit > Device settings.


I think you are on GRBL LPC or GRBL M3

Try this please
GRBL Types

Which one you have selected?
Did you use Find My Laser?

mine says custom gcode???

All are GRBL-LPC all are incorrect

They must be TOP Grbl selection
Or they wont work correct

Double click eah profile and change from GRBL - LPC to GRBL and OK

done that but the machine as soon as I ask to start a project it comes up with MC exceeds max range of motion it framed ok i manually focussed and then after start it says this???

PS I really appreciate your help

here is the last console reading after homing and focussing

I would triple check the belt tensions, they are not always correct from factory

Also you can disable alarm 1 if they give you problems
Help > Machine settings > hard limits toggle off and Write

What star from are you trying to run?
Use Absolute coordinates and run this little project on a bit of cardboard please
Dot Test with Angle.lbrn (46.3 KB)

as soon as I ask it to frame the machine halts with same warning

also I cannot find this setting


Type in console
Press enter

here is where it is now

Remember to click write.

Then try engrave again

yippee it now seems to be working all I have now as a problem is for Ikier to sort out why it will not autofocus and they are on holiday for the dragon boat race!!!
Once again thank you for your patience and all your help I only wish I could return the gesture.
kind regards


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.