Error 22 . This is so frustrating

Laser wont run . keep getting the Error 22 code ![ Ortur Laser Master 2 Ready!

OLF 137.

Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]


Starting stream


Feed rate has not yet been set or is undefined.

On or near line 4:

Stream completed in 0:00

[MSG:Pgm End]


What are you trying to do when you get this message?

I can’t do anything. Even tried a simple letter a and nothing happens

No power, no lights, no movement, no messages in software? Nothing? Is it plugged into an appropriate power source? This can not be. You posted console output, so something has “happened”. It can not be both things.

I was asking “What are you trying to do…”, meaning I am looking for a lot more detail. We are not there to “see” and try things for ourselves, so we only have your words. “Not working” or “noting happens” only tells us that you are having issue with getting things to work, but not much we can use to help sort. This may help in understanding what we are after to provide assistance of any value.

1 Like

OK … Well , there is power to the machine all lights correct lights are on . It will home and also frame with no issue but when i press start burn in moves less than a centimeter as if it is about to start burning but barely leaves the home. and then i get the error code 22 in the software and the console output “happens” but that is all. I’ve checked all wiring and settings but nothing is any different.

also i have the ortur laser master 2

the issue is new and i am running the latest version.

and running off of a MacOS Catalina

Please Speak…

@OrturTech, can you please help @noshorts1911 when you can? Thanks.

@noshorts1911, please save this file GCode and post here for review.

Thanks for your help Rick !

Error 22 is a new one
Could you
a) confirm you installed your Ortur manually as a GRBL device
b) print screen of your full lightburn window
c) save your project as .lbrn and post it so i can replicate please?

Is there a way to call and talk to someone ?

Also getting an alarm 8 for homing

Literally just trying to burn the letter A to test . nothing fancy at all.

First off, take a breath and order a cup of coffee. Start simple, what is the error message??? It’s “Feed rate has not yet been set or is undefined.” CNC machines need to know how fast to move, that’s the feed rate. If you tell it to move, but don’t tell how fast you gag the software, I.E. get that error message. Find a simple grbl command to send it via the console, such as $J=G21G91X0Y-5F600 This works find on my little cnc and moves the y direction by 5mm, if set in the mm mode. The negative sign might be required depending on your home quadrant. Mine homes to the rear left, the only direction available is negative direction.

Another indicator is that it fails “On or near line 4:”, so you should post at least the first five lines of the actual gcode for the support people to look at. Also double check your grbl configuration, especially any of the configuration that is a ‘maximum’ such as “$110 = 1000.000” (X-axis maximum rate, mm/min)." These are like speed limits, if one is set to zero it may be a problem. I would look “On or near line 4” before doing anything… and see what you’re telling it to do that chokes it. It’ll have to be a gcode move without a feedrate.
Maybe this will help in debugging: I sent >> $J=G21G91X0Y-5F600, which works, then the output when I remove the ‘F600’

> >> $J=G21G91X0Y-5F600
> ok
> >>> $J=G21G91X0Y5
> [Error] An error was detected while sending '$J=G21G91X0Y5': (error:22) Feed rate has not yet been set or is undefined. Streaming has been paused.
> [Error] Error while processing response <An error was detected while sending '$J=G21G91X0Y5': (error:22) Feed rate has not yet been set or is undefined. Streaming has been paused.>
> >>> $G
> [GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]
> ok

The $G is for the parser output, or what the machine needs to do for that command. Notice that the last two being the feed rate and spindle speed, I believe… Feed rate is 0. This relates to parsed output of the jog command ($J=G21G91X0Y5) that failed because the feed rate is zero. These are all techniques of debugging. After all it’s only a machine…

Above all relax and have fun, you’ll solve it! and :smile:

1 Like

Thanks Jack ! Although this has been the best response thus far, I am using an Ortur Laser Master 2. But getting a cup of coffee seems like a good idea right now . just been out of commission for almost a week now .

I don’t know how much you’ve dealt with this stuff, but I dealt with CNC machines from the 70’s, although being retired for a while I forgot about them until the low cost Chinese machines became available. With a 3d printer an a CNC machine you can change the tools, it’s almost like soft hardware… Change the spindle for a laser… It’s very easy to get frustrated, especially with the learning curve of this type of technology. Take it step by step and it’ll fall into place. Personally I’ve done more damage trying to stuff to work than when I sit and think about it for a while and look for other reasons for the problem. I upgraded my little 75 watt motor in my CNC to a 500 watt one. The z carriage would only bind in a few places. Did this for a month and finally realized the mounting holes for the stepper motor were too tight. Drilled them out by .3 mm and it went together and works fine now. Take your time and think it out. It’s all logical and predictable, it just doesn’t seem that way now… I retired out of IT and this is a very knowledgeable group with great support, make use of them but give them a chance. Take care

Thank you for that @jkwilborn.

@noshorts1911, I was just going ask why you responded, multiple times, never once answering the questions directly from the folks that make this gear?

We tried to offer you the hookup :wink: …direct access to the nice folks at Ortur. Gil asked specific questions to help sort this out, and you have not provided him a single reply.

I also asked for things. We are here to help, but you have to participate more than this to get any technical solutions to the issues you are having.

1 Like

I actually did participate , answered all questions asked and Gils questions were already answered earlier in the thread …Do I have to repost and explain the same issue to everyone who gets on the thread every time or is it up to them to read ? even a screen shot of my lightburn screen . is this not enough info? there is a letter dead on the screen and thats all i was trying to do

@OrturTech I have installed it manually . Sent a screenshot but here it is again, with the lbrn file attached. Screen Shot 2021-02-17 at 11.33.04 AM|690x346 for review lbrn.lbrn (18.1 KB)

I believe your problem is your settings
70mm/min btw is a bit slow. You might be thinking Inches? That would be roughtly 1700mm/min

Also on your interval mm, you have 100 lines interval (mm), which is 1 line per Inch


Try these please: