Error:5 Homing cycle is not enabled in your Grbl settings. again!

I have read everything i can find on this error. I have done it all. my system shows that home is enable. the thing worked fine for two different jobs then not even changing anything other that material i start getting errors. I have even uninstalled lightburn and reinstalled it. I am banging my head against the wall.

I have the longer ray5 10W

Screenshot 2023-03-26 122503
Screenshot 2023-03-26 122634

really need help please.

I’m not sure I know what you are asking… I think this says it’s not enable.


On mine, $20, $21 and $22 are enabled.


i turned those on and not im getting other erros. Im ready to give up. owned this thing for three weeks and have not got a thing out of it other than frustrations

new erros:


Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.


G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 2:

Stream completed in 0:00


Grbl 1.1 [‘$’ for help]

[MSG:Check limits]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]


Until you get a handle on these they can be frustrating. So calm down and we’ll see if we can get you into a zone it will do what you want.

Your settings may be that way because it does not have home switches, so it cannot complete a home operation.

Lightburn will also request a home cycle and you should disable that here… this will probably give you the error 5 you are getting. Also when you click the home button as your hardware doesn’t appear to have limit switches. Don’t copy my settings… but you can check the two circled.

You will have to place the head where you think home should be, one of the four corners… The origin in the device settings should also reflect where home is.

@berainlb is good with these, maybe he’ll drop by and give you some better assistance in getting it up and running…

I quickly ran through this link, maybe it will help you, it’s kind of basic…

Hang in there…


thanks for everyones help. I did so manything at once i am not sure but the off auto home on start up helped a bunch. im confused as to why it is now an issue but not for the last few weeks. even earlier today doing the exact same thing. how ever it seems to be working now. after reinstalling lightburn and the software update on the laser etc. learned a lot of things

thank you

I spoke to soon, i tried to start a material test and about on minute into it. it stopped and gave me an error “Your Grbl may not support Variable Power mode (M4)
If your laser does not turn off between cuts,
switch to the GRBL-M3 device”

like i said i have already done material test did two this morning before all my trouble. im at a lost. if i do the 1.1e then the material test is not going to do what I want and I did not do the 1.1e in the past just picked grbl.

hopefully someone has an idea on this.

This is informational and not necessarily a problem.

However, I did notice a problem in your device setup. You are configured to “GRBL-LPC” when you should be on “GRBL”. This is likely not a huge issue as they’re largely compatible but I’d suggest switching this over.

Push “Devices” button in Laser window, then click on the name of your laser, then Edit. Choose GRBL, then push Next until you complete the wizard.

Do not use M3.

ok I will change it. I just had another issue and im thinking it may be the root cause. I was trying to run a test grid on some acrylic and i had it upside down the the Tempera on top and it triggered a flame and gave me the same error so that may be the second issue. the others im guessing were self induced trying to fix things or break things in an attempt to fix. so many thing to remember

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.