Error: 7 on my atomstack A5 Pro

Never had trouble before but just downloaded the new software version and now getting below error code. I have tried using a new USB cord, as the software told me it was a bad usb connection. I have tried plugging laser and laptop into different circuits to see if that was an issue. Keep getting same error code. Any help would be appreciated…
Waiting for connection…


EEPROM read failed. Reset and restored to default values.



































Grbl 1.1f [‘$’ for help]




Target buffer size found


That ‘Error:7’ message is coming from your laser’s board, and is a known issue with a certain generation of Atomstacks that prevents users from writing firmware changes that persist through a power cycle.

We have a guide on re-flashing your laser’s firmware to resolve this issue. If the error code is not causing you any issue (are there changes you’re trying to make?), it’s not something you necessarily need to do.

I am getting an error 13 in Arduino when I try to load the .zip file I downloaded.

I should have mentioned…this is happening on lightburn. I haven’t tried to change anything with my Atomstack. I simply downloaded the new Lightburn software and turned the machine on to run a file. Never had any issues until now. I can’t seem to figure out what is wrong.

What are your goals with the Arduino IDE tool?
This is a pretty big leap from Error 7 in LightBurn.

I’ve flashed a controller to open source GRBL using that tool but I’m pretty sure i compiled it. Atomstack likely has nice clean binaries that are ready to go.

Which zip file did you download? A Link to the page it came from would be super-handy. I may not be too inclined to gamble with a blind download link.

If the Arduino IDE has connected to your AtomStack, it will lock the USB port and you won’t be able to communicate with it with LightBurn.

I was following the directions of the first poster. The zip file came from the link the support staff posted.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.