Error 9 gcode lockout

I keep getting the dreaded error 9 gcode lockout. I’ve searched the forums and read all the different posts about homing, shock error, etc. I’ve tried all the different solutions and none have made any difference.

I’ve also tried completely rebuilding my image, transferring it in as an svg, etc. My thinking was that maybe the image was a little too detailed (suspected this wasn’t the case but what the heck). This is just a blueprint outline of a tank with some text in it - 2 layers,

Sometimes the burn gets farther than other times but it always ends before it is complete.

Other things burn just fine. The laser chassis isn’t moving, if it were then other burns would fail.

Can you provide the following:

  1. screenshot of the error that you’re getting
  2. full screenshot of LightBurn with the design loaded and ready to burn

Thanks for responding. Below are the screenshots.

I’ve also tried different speeds thinking the higher speed might cause the laser to move. It can’t move but thought I’d try.

image

The error message is a bit unusual.

After the Shock detection message it looks like the laser is reconnecting which is when the error:9 is appearing.

Does the error:9 always follow the Shock detection?

In any case, if you are trying to laser a line drawing of that complexity at 20,000 mm/min you’re going to have a bad time. You’re likely around 2 orders of magnitude too fast for something like that. I’d suggest reducing speed to around 200 mm/min and testing behavior. Does it work in that case? Then you could empirically try increasing speed to see at what point you get the error and at what point the quality is compromised.

If that doesn’t resolve it, can you check the value of GRBL config $603? If you’re not sure about this then run ?? command in Console and return the output.

Ah ok, well I’d tried slowing it down before but not that low. I knocked it down to 2000 and it’s running now. Hopefully slowing it down will fix it! Fingers crossed.

Yes the error 9 always follows the shock.

ok, that worked. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.