Error Message on Laser Console

Hello Lightburn Team:
Like a lot of people on here, I am extremely new to this laser burning and Lightburn software. I’m finally close enough to try the laser but when I connect it, I get these messages. Can you point me in the right direction on how to correct it? If not, that’s fine as well.

Here is what it says on the console

Waiting for connection…

Grbl 1.1f [‘$’ for help]




Target buffer size found



Homing cycle is not enabled in your Grbl settings.


This message is from the GRBL control firmware, telling you that the controller does not have the setting for ‘Homing’ enabled. If you don’t have limit switches installed on the machine, turning on the setting would just give you a failure when it tried to home (and would make a horrible noise trying).

When you set up your laser in LightBurn you likely left the ‘Auto home on startup’ switch enabled. Turn that off, and it won’t send the homing command when you connect. You can disable that in Edit > Device Settings:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.