Error pop-up on Start button

I am running the YoraHome 6550-PRO 40 watt laser with Windows 10. And the latest version of LightBurn

I got the Laser Fire button to work but not the Frame button. When I press Start I get this error pop-up and the same with the Frame button. I prefer using the “Current position”.

Screenshot 2022-07-03 103108

Your Working Size in Device Settings is set for 3.875 in x 3.875 in. Do they accurately reflect the size of your working area? If not, start by adjusting that to the real working dimensions of your laser.

In addition, are you intimately familiar with how “current position” works? If not, I suggest you begin by starting with absolute coordinates until you become very familiar with how your laser functions.

LightBurn team has made a video on the behavior of the 3 “start from” modes.

1 Like

Those figures are the size of the “work piece” Set for making coasters. I used the “Current Position” on my first 6550 I have, never tried the absolute coordinates before. I just upgraded to the 6550-PRO. I can try the absolute coordinates. I’ll change the work area to the 26"x 20" and see what happens. Also the I forgot to say when I turned on the machine the very first time the laser went to the upper left corner instead of the lower left that I picked when setting up the PRO. Any thoughts on that? How do I change that?

The intent of those values is to set the overall work area, not the work piece. So suggest you stick to the full dimensions.

This isn’t something you get to pick (short of purposeful customization). If the machine homing to upper-left I assume that’s where it has limit switches. Can you verity? However, homing location is not necessarily the same thing as machine origin. Machine origin is what you are specifying (ie. as in telling LB how your machine is setup), not choosing (ie. as in choosing how your machine will behave). Machine origin indicates from what corner the coordinate system on your laser is based, essentially the 0,0 position.

Your laser is likely meant to have origin at lower-left as you’ve specified. But may very well home to upper-left. Your position after homing in that case is likely 0,20 inches. Can you confirm?

This is changeable but not without effort and you’d be moving away from default behavior for your laser. If you’re comfortable with that you’d have to relocate the position of the Y limit switch and then make a few changes in your GRBL configuration to change homing direction and offset your home origin so that lower-left is 0,0.

i really don’t know whats going on. The x-axis limit switch in on the laser stepper motor on the gantry. The y-axis switch is on the right rail in the right front corner. However, the x-axis rail never goes to it. The machine only goes to the x limit switch. Why it does not go to the y switch I have no idea. In the Device setup screen it asks where the origin of the laser. If I click on anything but the left front the work item is either upside down or backwards. I’m about ready to delete LightBurn and re-install it with the old version and start over. I did not have any trouble with LightBurn before installing the updated version.

The issue is almost certainly not related to the version of LightBurn. In fact, LightBurn isn’t involved in how the machine homes.

So a few clarifying questions:

  1. Where did your machine home to before the upgrade?
  2. If you’re saying the machine is moving in a direction that’s not toward the limit switches then is it crashing into the back? Or does it stop appropriately? Homing direction can be changed but it’s also not something that should spontaneously changed. This would require you to have input a setting change or modified a value in Machine Settings.

I may not have been clear enough in my last post. This isn’t something you get to choose. There’s only one correct answer for a particular laser. In this case sounds like front-left. This is unrelated to homing direction and unrelated to home location.

Can you run this command in Console and return results along with answers to the questions?

  1. Front Left
  2. When I click the Home switch the laser goes to the left frame where the x-limit switch.
    However the gantry does not move to the y-limit switch is in the Front Right corner by the power box. The Y-axis does not move at all. If I go to the Move screen and press either one of the y-axis the error message pops up. The Fire works but not the Frame button. The Frame button will also show the error. I have tried both the Absolute Coords and Current Position.
    Screenshot 2022-07-05 123552


Grbl 1.1 [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]





[MSG:Using machine:LKS TS3]



You’re saying you don’t get any Y movement at all? You indicated in an earlier post that the machine attempted to home to the top-left corner? When did that occur and was it only one time?

Please run these commands in Console and return results:


Also, can you include a full screenshot of LightBurn?

Sorry for not making myself clear. I thought it Homed to the top Left corner but what it was is the gantry was all the way back and when i pressed Home the laser moved to that corner. And yes. There is no movement of the y-axis at all. If using Absolute Coors The laser will turn on but only for one line because of the y-axis not moving. If I use the Current Position the error message pops up. If I press Home the laser will go to the Left rail where the limit switch bracket is located is but that is all again, due to the y-axis problem.




































































Okay. Interesting. So it’s good that the behavior is consistent and indicates it might not be due to a changed setting.

Can you check the wiring for the Y stepper and make sure it’s plugged in properly and firmly on both side of the cable?

If you use the jogging controls, are you able to move left right? And are you getting the error message for both up and down? Is there any Y movement at all?

I don’t see anything obviously wrong in your configuration. There are some non-standard parameters I’m not familiar with but I don’t think they would affect this.

My guess to what’s happening is that you have a hardware issue on the Y-axis which is preventing your machine from completing homing. This is why your coordinates are likely off and why you are getting the soft limits error.

Look over your cable and do a general mechanical review for anything that could be causing Y to not move.

If you can’t find anything obvious, try swapping the stepper ends of the X and Y cables. Does the issue move motors or stay on the same motor. If it moves then the issue is with the original Y cable or the controller. If it stays on the same motor then the issue could be with the stepper itself.

I swapped the x & y and the y moved back and forth,so I guess I’ll contact YoraHome about this and get solved one way or another. Want to thank you very much for your help and patience.


Interesting. Check to see if it’s a cable problem or controller problem. Use the known working original X cable and plug into Y port on controller and motor. If it works then it’s a cable issue. If it doesn’t work then a controller issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.