Error: “There was a problem sending data to the laser. System may be busy or paused”

  • What machine do you have? Creality Falcon 2 Pro 40W
  • What controller does it have , and what firmware it is running? Unsure, but maybe GRBL
  • Are you running the latest version of LightBurn? Just downloaded it a couple days ago!
  • Is the issue new, or has it happened before? What kind of computer is it, and what Operating System is it running? Lenovo laptop, Windows 11 Home version

Caution. NEW USER!

This seems to be a reoccurring software alert, as many folks have written into the forum with this experience over several years. Please bear in mind that this has been an intermittent failure, and the machine has worked both before and after the fault, which might tend to narrow down the possible solution.

I seem to be encountering this error when I turn on the machine and try to begin new work after I THOUGHT I properly closed out the previous work session. The Frame and/or Start command from Lightburn results in nothing happening.
I was able to resolve the problem this past Thursday night, but not sure what I did to clear the error, and today, it’s back again, and I’m unable to proceed.
All I’m able to do is use the Home command on the machine itself to get the laser to return to front left.

“There was a problem sending data to the laser. System may be busy or paused”.

There are no open files in my Documents that I’m aware of, although the error message seems to conclude otherwise. I see many users have discovered this same error, but with no clear fix-all solution.

I’ve read about possible USB solutions, but I’ve tried unplugging and replugging, AND there’s the clear fact that the cables have worked properly both before and after the fault during the past 48 hours, so it seems to me it’s not a cabling issue. I’m using brand-new cables supplied with the machine.

My main machine power light is also flashing green. Is that right, or should it be a steady green light?

I’ve also noticed that my sliding cover lights are not working and I can use the laser with the cover open or closed! Clearly, this safety feature is not working properly, so I’ve tried to check the two plug connections which ought to be responsible for this circuit. But again, the machine HAS WORKED with the sliding cover open or closed, so to me, that seems like a secondary problem.

Perhaps this may be enabled/disabled in GRBL settings.
Try selecting your laser in the dropdown box on laser window.
image
For connections troubleshooting: