Errors using GCode

Hello all,
I’m EXTREMELY new to LightBurn and Laser engravers. I love the ease of lightburn however when trying to complete my first engraving, I imported a jpg logo and tried to use it. I received an error 2 on line 142 and also received error 9. I don’t even know where to begin to figure out how to resolve this. I have a Stump Laser engraver. Any direction anyone can give would be GREATLY appreciated.

Error 2 or Alarm 2?

Alarm 2 is out of bounds, Error 2 is invalid format. Error 9 is trying to run while locked, which happens after Alarm 2 if you don’t reset.

I suspect you tried to run the machine out of bounds, which means you might be in the wrong origin mode. Read here to understand what I mean by that:

Let me know if this helps or you’re still stuck.

Thank you soo much for the quick response. I switched it to absolute coordinates then is started to engrave then stopped with " error:24
On or near line 245:
Stream completed in 0:10"
I don’t even know how to view line 245 so see what the error is.

Error 24 is: “Two G-code commands that both require the use of the XYZ axis words were detected in the block.”

That seems more like the controller missed some data during transmission, because the commands sent by LightBurn are generally pretty simple, and if it was wrong, a lot of people would have this issue.

To see the gcode, just click ‘Save GCode’ and save it to a file, then open that file in a text editor like Notepad.

In the console window in LightBurn type $i and press enter. Copy and paste what the controller responds with here.


Also I went to file save as and it saves it as a lightburn file I don’t see where the option to “save gcode” is.


This was just to double check that the controller you have is using the same values for buffer space as what I was expecting, and it is, so that’s not the issue.

Thank you for checking, I restarted my Laptop (Mac) and the laser but still got the error. Also Thank you I was able to save the Gcode however I have no idea what to look for.

So I opened lasergrbl just to test and though the image printed backwards it did work.

Check to see if you’re using ‘Buffered’ or ‘Synchronous’ mode in LaserGRBL. LightBurn uses the buffered mode because it gives better performance, but it’s also less forgiving.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.