Etching on glass jars is skewing the image

I have been lasering tumblers with a PiBurn rotary and have that down but when I try to etch glass jars, the images come out skewed, a tall, skinny image and the banner that goes across the image is wavy. I’ve changed the steps in rotation to get the width shown in the picture but it’s still not quite right and you can see the Backroads part is starting to wave. I’m sure it’s a setting that I’m missing but I don’t understand why the tumblers work perfectly but these glass jars are causing a headache.

If you’re able to get clean engravings on tumblers this is mostly likely due to slipping. What’s your holding strategy for this? Can you include a picture of the jar in the rotary as if you’re ready to engrave?

Have you adjusted acceleration and speed settings? What have they been set to for this?

@jkwilborn, don’t you have a PiBurn? Any insight here?

Hi Shelly… Nice to have you aboard…

WIth a PiBurn or any ‘wheeled rotary’ you should not need to change anything in the configuration such as step length or motor steps/rotation. So put it back to where it was. When these are configured, the wheel will move the same amount as the Y table would have moved, so once set, they should be good. Since it’s driven by a wheel to the surface of the object, diameter makes no difference. The surface speed will always be the same as the ‘driving’ wheel.

The change is only needed when you have a ‘chuck’ rotary and the software needs to know the diameter or radius to compute the surface speed or how fast the ‘Y table’ would be moving…

I have a PiBurn V3 that I use. How are you holding the object ‘down’? Can you get the ‘hold down’ into the bottle?

Might be a dumb question, but is the jar perfectly circular? If not this will translate to distortion in the image as the distances are not linear. Had a few of these with some low cost canning jars…

It looks like an awfully ‘hot’ burn. I’m also assuming that it’s a scan and not a vector, that’s what it looks like. Are you using the X axis aggressively? How fast are you scanning?

Check your Y configuration and ensure that the acceleration values are ‘low’ and the intitial speed is also low.

Check ‘start speed’ for Y in the Engraving and Cut areas of the ‘Edit → Machine Settings’ is low, mine is 5mm/s. This is the ‘start movement’ of the axes, so slow it down.

There are a few places to modify the controllers settings and most are in the PiBurn Setup manual.

In the Y Axis section, there is also Max acceleration and Max Speed. Most of mine are set around 5.

Make sure you have a backup of the configuration so you can reload it when you go back to ‘no rotary’…


I am attaching several pictures to answer questions. I watched the jar as the system was resetting due to being off last night and I do believe there is some slippage that I didn’t catch before. Is there a way to solve that?

Notice the acceleration values and

There is also at least one in the Vendor settings…

I didn’t lower the Max speed of the Y axes. Haven’t tried to spin anything that fast (Max Y), but keep in mind that many things probably wouldn’t stay on the rotary…

You want the Y axes to move the least amount and at the slowest rate and acceleration.

Make sense?

Backup before meddling…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.