Ethernet connection - unable to send jobs (machine busy?)

So I’ve searched here, and lots of folks appear to had have this issue, but most seem to have been connected via USB. I’m wired ethernet to my Ruida laser controller. I can see the camera, I can manually control the laser head via the LB interface, and I can even run a preview frame of the job. Everything looks just fine, until I hit the [Start] button, at which time it pauses, then throws up the usual “there was a problem sending data to the laser. the machine may be busy or paused” error. My machine is neither busy nor paused. I’m on LB v1.4. I checked the console, and it shows nothing. It’s grayed out completely. Is that normal for a network connection? I’ve never opened it before, so I’m not sure what it’s supposed to look like.
Any ideas? This is just weird. I haven’t used LB in a while, but v1.2 was working fine, last time I ran a job.

No this isn’t normal…

The Ruida is a great controller, but it’s communications skills, are in my opinion, are lacking… Even though it runs over Ethernet it’s UDP, so there is no error control.

Are you going directly from the computer to the Ruida or is it on the local lan?

I don’t know if you can operate the console when it’s loading code, but I’ve watched my console and it doesn’t gray out…

Just had the spouse send a large graphic file to the Ruida and there was no indication on the console of anything…

Is the Lan indicator showing it’s connected? It’s in the bottom right part of the Ruida console on my 6442g


Ruida controllers don’t use G-Code, so the LightBurn Console has nothing to do or say; being inert & gray is its normal condition.

Although you’re using Start (which reuses the tempfile directory entry), the controller’s internal flash drive may have filled up with enough other files over the years that there’s no room left. Use the File List window to see the drive contents and throw out whatever isn’t needed.

My Ruida does not gray out the console for any reason that I’ve seen…

Haven’t tried to use the console when it’s loading a file over Ethernet, but it does not gray out



I was thinking of the LightBurn console, as used for G-Code.

If it is, indeed, the machine console on the fritz, then things get interesting!

So sorry for the delay, I wasn’t receiving notices of the replies!! :frowning:
Thanks for all the feedback, folks.
When I said the console was grayed out, I meant the console window in Lightburn.
That was one of the troubleshooting steps that was mentioned in another topic, so I figured I’d include that info.
My machine control panel works properly. :slight_smile:
The laser is connected over my local LAN, through a switch, as is the normal way with such things.
It’s not a direct cable connection from my PC to the laser.
Everything had been working perfectly up until recently. The only thing that’s changed, as far as I can recall, is that I updated LB from v1.2.xx to v1.4. I haven’t been using the laser a lot lately, so my software was behind a bit.
Oddly, I can (as noted in the OP) control everything over the LAN manually, I just can’t send a file.
I’ll check the file list next time I have it powered on, but I don’t think there’s all that much on there.
If I transfer the cut file to the machine via flash drive, it will run the job without issue.

Did you follow @ednisley suggestion of clearing out all the files you don’t need from the Ruida memory?


As I said in the last post… I’ll check the file list next time I have it powered on
I don’t use this machine every day, and I just posted that last night. :wink:

I seriously doubt that’s the problem, since it was working fine the last time I used it, and no files have been added between then and now. I will absolutely try that, though, since I’m sure it’s time for some housekeeping anyway. :sweat_smile:

The Ruida seems a bit cranky when it’s memory gets full…

Some people have had problems actually deleting the files. If all else fails, try deleting all of them, at once, via Lightburn after a refresh.

Good luck


No dice on clearing the internal file list.
I wiped everything, restarted the machine, and tried sending a simple test file (see attached), and got the same error.

To reiterate the situation:
I can

  • the machine shows as connected on the status line at the bottom of the screen
  • I can control the laser head manually via the [Move] panel
  • I can run a preview “frame”, and watch the head move via the camera preview
  • Save an .rd file to a flash drive, walk it to the machine, and run it from the controller directly

I cannot

  • Run a job using the (Start) button in the [Laser] panel
  • Send a file to the controller using the (Send) button, also on the [Laser] panel

I’m lost here. All I can think of is to uninstall LB completely and see if I have a copy of v1.2 lying around to try. Is that worth a shot? That’s the only thing that’s different between now and when this was all working.

It will allow you to read the file list from the controller and delete the whole list?

Can you read the machine settings?


Yes, I was able to read and delete the file list.
I can read the machine settings, including vendor settings.
I can do absolutely everything, except send any data to the machine from LB! :frowning:
I even tried to run the camera calibration, and that failed as well.

So I uninstalled LB v1.4 completely and reinstalled v1.2, and everything works perfectly again.
I guess there’s some sort of bug or issue with v1.4? I’ll stick with v1.2 for now, and see if things get sorted out with the next release. Thanks everyone for the help.
If we figure out a way to get v1.4 working, I’d love to hear about it.

If you can duplicate this, I’m sure the Lightburn people would like to hear about it…

Generally when you make changes, those changes are rarely done with communication calls… meaning the interface to the system os for Ethernet probably doesn’t change. If you can break that, I’m sure they want to know.

Maybe @Rick can suggest a proper procedure to get this information to the developers…


This is almost certainly a false positive. Possibly a corrupt install of 1.4. I’d suggest installing the most current version and trying again. If it’s indeed a problem with 1.4 series then it’s an easy fix to get back.

Thanks for the suggestions, but I’ve already invested far too much time and effort into tracking down this issue already. If the Lightburn Devs want to know more about it, they have pretty much everything they need in this thread. I’ll stick with v1.2 for now. It works okay, and seems to be stable. I’ll keep tabs on the changelog, and if they end up adding something I feel I just can’t live without, I may risk updating again in the future, but it seems unlikely at this point. I’m sorry to sound disgruntled or ungrateful, but you guys can’t imagine the heartache this has caused me. I’ve been totally down for a couple weeks now, and it turns out to just be bad code. I don’t think it was a corrupt install, since I had already tried reinstalling v1.4 a couple times prior to asking for help here.
Anyway, it’s working now, so I’m good. Thanks again for everyone’s help! :smiley:

Thank you @jkwilborn, for drawing our attention.

Thank you @Elmojomo, for providing this detailed information. :slight_smile:

Yes, this is normal, but not because of how you are communicating with the laser. The reason is DSP vrs GCode. The ‘Console’ window is designed to provide near real-time feedback when working with GCode based systems. The console window allows you to directly input commands and see messages from the controller itself. This “grayed-out” view is expected when using a DSP device profile.

Investigating further and will post back as additional questions and learning unfolds.

There are a few additional bits we like to collect if you are willing. :slight_smile:

Wired or is this a wireless connection to your network?

The Debug log, the Support Data, and the most recent lbprefs file would be informative.

Launch LightBurn as if you were approaching the job the same way as before.

For the Debug Log:

  • Click Help, click Enable Debug Log and start your job. When you exit out of LightBurn the file LightBurnLog.txt should be available in your Documents folder.

For the Support Data:

  • Open Notepad (or any text editor) and click Help in LightBurn, then click Generate Support Data. The encrypted data automatically arrives on your clipboard. In Notepad, click paste and save the file as ‘Support Data Forum 108173’.

For the Prefs file:

  • Click File, click Export Prefs and Save that as ‘Forum Ethernet connection 108173.lbprefs’

Please Email those 3 files to for review. In the Subject line, please include:

Attn: Rick Re: Forum - Ethernet connection - unable to send jobs (machine busy?) 108173

Be sure to delete the LightBurnLog.txt from your documents folder after you send it to prevent continued logging.

I will be using these files for further investigation and report generation. Please let us know when you send, Thank you.

Hi Rick!
Thanks for checking in.
I’d be happy to help, but since I don’t have v1.4 installed any more, I can’t replicate the issue, sorry.
I can confirm that my laser is connected via a wired LAN all the way from my desktop to the machine itself.
I do have a wireless network in my shop, which I use for the camera and some other stuff, but the machine itself it wired ethernet.
Sorry I can’t provide more details.

If you do see unexpected behavior, using any version, we would like to know and receive as detailed information as possible. Hard to resolve issues we are not seeing in our testing and usage. We take user reports very seriously, and work diligently to reproduce and resolve.

As an FYI, all versions of LightBurn public releases can be found here: